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Revisions to this Manual

This manual revision adds the following information compared to version
GFK-1362:

• Procedures added for registering your software and transferring a software
license (Chapter 1).

• Chapter added to explain the use of CIMPLICITY Motion Configurator, a
software application new to Release 2.0 of CIMPLICITY Motion (Chapter 2).

• Information added about the following new features in CIMPLICITY Motion
Programmer:  backup and restore (Chapter 3); Duplicate command (Chapter
4); the While/End While and Synchronize components (Chapter 4); the user-
defined component feature (Chapter 5).

• Throughout the manual, information was added about the new motion
controllers supported by Release 2.0 (the Motion Mate APM300 and Motion
Mate DSM300 series of controllers).

• Additional connection information was added to Chapter 6, and Appendix A
was created to provide detailed cable and connector specifications.

• Appendix B and C were added to provide a quick reference for native
programming languages used within the Text component.



Preface

iv Using CIMPLICITY Motion –November 1997 GFK-1362A

Content of This Manual

Chapter 1. Introduction:   Describes PC requirements to install and run CIMPLICITY Motion,
how to install and uninstall the application, and how to use online help.

Chapter 2. Using the Motion Configurator:   Explains how to use CIMPLICITY Motion
Configurator to configure the parameters of your motion controller.

Chapter 3. Starting Work with the Motion Programmer:   Introduces you to CIMPLICITY
Motion Programmer

Chapter 4. Using the Motion Profile Editor:  Describes how to work in CIMPLICITY Motion
Programmer’s motion profile window, create and edit a motion profile, and edit the
motion components’ parameters.  Provides an explanation of each component.

Chapter 5. Creating Custom Components:  Explains how to create your own user-defined
components in CIMPLICITY Motion Programmer.

Chapter 6. Communicating with the Target Controller:  Describes how to connect your
personal computer to the motion controller and how to upload and download motion
profiles.

Appendix A. Connection Details:  Provides details about the cables and connectors used for serial
communications between your personal computer and the motion controller.

Appendix B. RS274 Language Reference:  Gives you a quick reference to the G codes used in the
RS274 part programming language.

Appendix C. Motion Mate APM/DSM Language Reference:  Provides a quick reference to the
APM300/DSM300 programming language.

We Welcome Your Comments and Suggestions

At GE Fanuc Automation, we strive to produce quality technical documentation.
After you have used this manual, please take a few moments to complete and return
the Reader’s Comment Card located on the next page.
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Introduction

CIMPLICITY® Motion for Windows® 95 and Windows NT® 4.0 consists of two
programs designed to make setting up and programming your motion controller faster
and easier.

CIMPLICITY Motion Programmer allows users to create motion profiles
(programs) for GE Fanuc’s Power Mate H, Motion Mate™ APM300 Series, Motion
Mate DSM300 Series, and Motion Mate MCS700 Series motion controllers.  This
application provides a user-friendly graphical programming environment featuring
drag-and-drop icons called components that connect to form a motion profile.

With CIMPLICITY Motion Programmer, you will be able to:

• Create a motion profile,

• Configure selected axis parameters,

• Download a motion profile to the motion controller or upload a motion profile
to your PC.

CIMPLICITY Motion Configurator provides tools for configuring the parameters of
your Power Mate D, Power Mate H, or Motion Mate MCS700 Series motion
controller. The Configurator features a Wizard, which asks you a series of questions
about your controller and motion control application, then sets parameters for you.

With CIMPLICITY Motion Configurator, you will be able to:

• Create and edit editions, which allow you to configure the parameters of your
target controller for a specific application,

• Download and upload configurations to and from the motion controller,

• View detailed information about each parameter for the target controller.

Chapter

1
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Chapter Contents

This chapter provides the following information:

• Requirements and procedures for installing and uninstalling CIMPLICITY Motion

• How to register CIMPLICITY Motion software

• How to transfer a license

• How to use online help
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Setting Up CIMPLICITY Motion

This section provides the minimum system requirements for running CIMPLICITY
Motion on your computer and tells how to install the program.

Before You Begin

Your system must meet the following minimum requirements in order to
successfully install and run CIMPLICITY Motion.

For Windows 95:
Minimum Recommended

CPU 486DX/33 Pentium

RAM 8 MB 16 MB

CD-ROM Yes Yes

For Windows NT 4.0:
Minimum Recommended

CPU Pentium Pentium

RAM 24 MB 32 MB

CD-ROM Yes Yes

You should also check the Important Product Information document shipped with
your release for any last-minute changes to these requirements.
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Installing CIMPLICITY Motion Software

The installation instructions given here assume that the CD-ROM drive is D.  If you
have assigned another drive to the CD-ROM, make the appropriate substitutions in
these instructions. The Motion Programmer and Motion Configurator are installed
separately.

To Install CIMPLICITY Motion Programmer:

1. Place the CD-ROM in the CD-ROM drive.

2. To view the contents of the CD-ROM, click D: from Explorer or File Manager.
Double-click the icon beside setup.exe. The CIMPLICITY Motion Setup Screen
will appear.

3. Follow the directions in each setup window. In the CIMPLICITY Motion
Product Options dialog box be sure to click the CIMPLICITY Motion
Programmer icon to install the Motion Programmer.

This setup allows you to run CIMPLICITY Motion Programmer in demo mode.
Demo mode supports only five components and does not allow you to save a motion
profile. You must register the software to run CIMPLICITY Motion Programmer in
authorized mode, which provides access to all functions of the software.

To Install CIMPLICITY Motion Configurator:

1. Place the CD-ROM in the CD-ROM drive.

2. To view the contents of the CD-ROM, click D: from Explorer or File Manager.
Double-click the icon beside setup.exe. The CIMPLICITY Motion Setup Screen
will appear.

3. Follow the directions in each setup window. In the CIMPLICITY Motion
Product Options dialog box be sure to click the CIMPLICITY Motion
Configurator icon to install the Motion Configurator.
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Registering CIMPLICITY Motion

If you have not registered your software, CIMPLICITY Motion Programmer will
run in demo mode.

To register your software:

1. After you have installed CIMPLICITY Motion Programmer, you will be
automatically asked if you want to register the software. To register the
software at another time, select Options Setup from the CIMPLICITY Motion
program group or select License Authorization from Motion Programmer in the
Windows 95 Start menu.

2. Read the Software License Agreement and click the Yes button to continue.

3. The registration information dialog box will appear. Click the Next button to
continue.

4. In the User Information dialog box, enter the information requested including
the 10-digit serial number from the back of the CD-ROM case. Click the Next
button to continue.

5. Before you can continue, you must contact the CIMPLICITY Registration
Center by phone or fax to obtain your authorization code. You must provide the
System Key Code displayed on the screen.

• To register by phone, call 1-800-273-1304 within the U.S. and Canada or
610-437-9528 outside of the U.S. and Canada.

• To register by fax, click the Print Registration button to print the required
information. Fax the printout to 610-437-4212

6. Type the authorization code then click the Next button to complete the
registration process.

7. You will need to restart your computer before running CIMPLICITY Motion.
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Transferring Your Software License

The license transfer procedure allows you to transfer your system license from one
computer to another (or to multiple computers if you have purchased more than one
system license). Once you transfer your license, the target computer will be fully
authorized and the source computer will run only in demo mode.

To Transfer a License:

1. Install CIMPLICITY Motion Programmer on the target machine.

2. On the target computer, select License Authorization from Motion
Programmer in the Start menu.

3. Click the Transfer License button then read the License Processing dialog box
and click the Yes button to continue. The Transfer License dialog box will
appear:

4. Insert a formatted disk into the target computer.

5. In the Transfer License dialog box, click the Register Diskette for Transfer In
button.

6. On the source machine, select License Authorization from Motion
Programmer in the Start menu.

7. Read the License Processing dialog box then click the Yes button to continue.
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8. Remove the diskette from the target computer and insert it into the source
computer.

9. In the Transfer License dialog box, click the Transfer Authorization Out by
Diskette button.

10. Remove the diskette from the source computer and re-insert it into the target
computer.

11. In the Transfer License dialog box, click the Transfer Authorization In by
Diskette button.

Uninstalling CIMPLICITY Motion

If you need to remove the CIMPLICITY Motion software from your hard drive, do
not delete the program; instead, uninstall the application using the uninstall
program distributed with CIMPLICITY Motion.  The uninstall procedure
permanently removes the application and all associated files from your hard drive.
The Motion Programmer and Motion Configurator must be uninstalled separately.

1. In Windows 95, click the Start button, select Settings from the menu, then
choose Control Panel.

2. Double-click the Add/Remove Programs icon.

3. Select the Install/Uninstall tab.

4. Select CIMPLICITY Motion Programmer v.2.0 or CIMPLICITY Motion
Configurator v.1.0 from the list of programs.

5. Click the Add/Remove button.
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Using Online Help

When using CIMPLICITY Motion, your primary source of information will be the
Online Help.

Online help is designed to give you quick, easy-to-access information about
CIMPLICITY Motion topics.  Use Help to get general information about a product
feature, to learn how to perform a specific procedure, or to find the definition of an
unfamiliar term. The three ways to find information in Help are by viewing the
Help contents, performing a Help search, or using context-sensitive help.

Help Contents

The Contents tab of Help shows the main topics covered in Help. To access the
Help Contents, choose the Help menu, select CIMPLICITY Motion Programmer
Help Topics, then click the Contents tab.

Figure 1-1.  The Help Contents tab for CIMPLICITY Motion Programmer

TIP
To access Help
information about
Windows 95, click
the Start button
and choose Help.
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Double-clicking the topic name or the book icon beside it “opens” the book and
displays the topic’s subheadings.  To view the contents of one of the subheadings,
double-click the subheading’s name or its icon.

Searching in Help

The Index tab of Help allows you to find a specific topic  or scroll through an
alphabetical list of topics in the index.  The Find tab of Help allows you to view
topics containing words you type in the search box.  To access the Help Index or
Find tabs, choose the Help menu, select CIMPLICITY Motion Programmer Help
Topics, then click the Index tab or Find tab in the dialog box.

Figure 1-2.  The Help Index tab for CIMPLICITY Motion Programmer

To initiate a search, type the topic name in the field or scroll through the list.
Double-click the selected topic to access help on that topic.



1-10 Using CIMPLICITY Motion  – October 1997 GFK-1362A

1

Context-Sensitive Help (F1)

Using context-sensitive help, you can quickly access specific information about the
active window, dialog box, or menu selection by pressing the F1 button or by
pressing the Help button contained in most dialog boxes.
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Using the Motion Configurator

CIMPLICITY Motion Configurator is a tool to help you configure the parameters
for a particular application and download the settings to your Power Mate D, Power
Mate H, or Motion Mate MCS700 Series controller. The Motion Configurator
allows you to view and change parameters in three ways:

• Configuration Wizard:   the Wizard asks you a series of questions about your
controller and application then configures the parameters for you

• Category Window:  the Category window groups parameters by category.
Detailed online help explains each setting.

• List Window:   the List window displays parameters by number and shows the
parameter’s status.  This is similar to how they are displayed on the controller's
operator interface screen.

For information about connecting your PC to the target controller and downloading
and uploading parameters, consult Chapter 6, “Communicating with the Target
Controller.”

With Motion Configurator, you will be able to:

• Create and edit editions, which allow you to configure the parameters of your
target controller for a specific application

• Download and upload configurations to and from the motion controller

• View detailed information about each parameter for the target controller

Chapter Contents

This chapter provides the following information:

• How to create, edit, import, or export an edition

• How to configure parameters using the Configuration Wizard, the Category
window, and the List Window

Chapter

2



2-2 Using CIMPLICITY Motion  – November 1997 GFK-1362A

2

Getting Started with CIMPLICITY Motion Configurator

When you start the CIMPLICITY Motion Configurator for the first time, you will
need to set the folder and select the Power Mate controller. Perform the following
steps to initialize the system:

1. From the Program Menu, select CIMPLICITY, Motion, Motion Configurator.
The Set Folder dialog box will appear.  Select the path for the configuration file
and click OK.

2. The New Edition dialog box will appear, as shown below.  Select the
Target Platform and configure the number of axes for your controller.
Click OK to continue.

At this point, the Edition window will appear. This window displays any existing
editions in the current project folder and allows you to create new editions or edit
existing ones.

You begin your work by creating or editing an edition.  An edition contains all the
configuration information for the target motion controller. You can view
configuration details by categories or by parameter list. An arrow  will appear
beside the active edition in the Edition window.

Editions are stored in a project folder. A project folder should be created for each
type of controller you have (for example, Power Mate D, Power Mate H). You can
also create project folders for individual controllers or for individual projects;
however, a project folder and any editions it contains can target only one type of
controller. The current project folder is listed on the status bar at the bottom of the
Editions window.
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Figure 2-1.  Edition window

Accessing the Edition Window

The Edition window automatically appears when you start up the Motion
Configurator. If you are in another window of the program and want to return to the
Edition window, do one of the following:

• Go to the View menu and choose Editions or

• Click the View Editions toolbar button .
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Creating or Editing an Edition

The Edition window displays all of the editions created for the current project
folder.

To create a new edition

3. From the Edition window, go to the File menu and choose New or click the

New Edition toolbar button .  The New Edition dialog box will appear:

Figure 2-2.  New Edition dialog box

4. Specify the number of axes for the target controller. Since editions are
identified by number only, you may also want to type information about the
edition in the Description field.

5. If this is the first edition for the project folder, click the drop-down arrow
beside the Target Platform field to specify the type of controller you are using
for that project folder.  If the target controller has already been set for that
folder, you will not be able to change it.

6. Click the OK button.  Basic information about the edition will then appear in
the list in the Edition window.

To edit an existing edition:

From the Edition window, edit an existing edition by clicking the box to the left of
the edition you want to edit.  An arrow  appears beside the active edition.
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To copy an existing edition:

1. From the Edition window, go to the File menu and choose New.

2. In the New Edition dialog box, click the Copy Edition button then select the
number of the edition you want to copy from the Available Editions scroll box.

3. Click the OK button. A new edition will be created.

Changing the Project Folder

The project folder contains all of the editions for the specified controller or
controller type.  If you are also using CIMPLICITY Motion Programmer, the
project folder will also contain the motion profiles and all subroutines.

To create a new project folder:

1. From the Edition window, go to the File menu and choose Set Folder. The Set
Folder dialog box will appear:

Figure 2-3.  Set Folder dialog box

2. Specify where you want the new folder located by choosing the drive and
double-clicking the folder in which you want your project folder to be stored.
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3. Click the Create Folder button.  The New folder dialog box will appear:

4. Type the name of the new folder in the field and click the OK button.

5. Click the OK button in the Set Folder dialog box.  The parameter editions
window will be refreshed and the New Editor dialog box will appear.

Selecting an Existing Project Folder

Select an existing project folder by doing the following:

1. From the Edition window, go to the File menu and choose Set Folder.

2. Choose the appropriate drive and double-click the folder you want.

3. Click the OK button.  The editions for the selected project folder will appear on
the screen.

Importing/Exporting Editions
The Motion Configurator allows you to import or export editions to or from an
ASCII file.

To import a new edition from an ASCII file:

1. Go to the File menu, choose Import/Export, and select Import Edition by ASCII
File. The Import New Edition from File dialog box will appear.

2. Click the drop-down arrow beside the Look In field to locate the folder where
the file resides.

3. Click the file in the list box and press the Open button.

To export the current edition to an ASCII file:

1. Go to the File menu, choose Import/Export, and select Export Edition to ASCII
File. The Export Current Edition to File dialog box will appear.

2. Click the drop-down arrow beside the Look In field to specify the folder where
you want the file to reside.

3. Type the file’s name in the File Name field then click the Save button.
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Configuring Parameters

CIMPLICITY Motion Configurator gives you three ways to configure parameters
for your motion controller:

• Configuration Wizard:   This tool gives you a fast and easy way of setting up
your motion controller. Based on your answers to questions about axes, servo
motors, travel limits, and other configuration topics, the Wizard builds a
configuration for you.

• Category window:  This window features tabs grouped by configuration
categories such as Axis, Travel, and Velocity and provides a convenient
Windows interface for viewing and changing selected parameters.

• List window:   This window lists the number, value, and status of all
parameters in the target controller. You can obtain a description of a selected
parameter by double-clicking its number.

Using the Configuration Wizard

The Configuration Wizard is a tool that builds a configuration for you based on your
selections in the Configuration Wizard dialog boxes. Based on your answers to
several questions, CIMPLICITY Motion Configurator creates a custom
configuration that overwrites any existing configuration data in the current edition.

To access the Configuration Wizard:

• Go to the Tools menu and choose Configuration Wizard or

• Click the Configuration Wizard toolbar button .
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To use the Configuration Wizard:

1. From the Overview screen, confirm that the Wizard is targeting the correct
controller and edition then click the Next button.

Figure 2-4.  Configuration Wizard:  Overview screen

2. Read the directions on each screen of the Wizard then click the Next button
when you are done configuring the parameters for each axis. To obtain a more
detailed explanation about any of the fields in the Wizard, click the Help
button.

3. The last screen, Configuration Complete, allows you to print and/or save your
settings. If you choose to save the settings, the Wizard will create a custom
configuration that will be stored in the specified edition. Any existing
configuration data in that edition will be replaced by information generated by
the Wizard.
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Using the Category Window

The Category window features several tabs that group parameters by category. Click
the tab related to the configuration information you want to view or change. To
obtain more detailed information about the settings on a particular tab, click the
Help button. Online help also provides the parameter and bit number for each
setting.

Note

Any changes you make in this window will override settings made
by the Configuration Wizard.

To access the Category window:

• Go to the View menu and choose ByCategory or

• Click the View Parameter List toolbar button .

Figure 2-5.  Category window:  General tab
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Tab Details

The parameters that may be configured for a motion controller are presented in the
dialog box.  For a detailed description of each of the fields, consult the
documentation for your target motion controller.

The tabs available in the Category window are as follows:

• General:  displays general information (such as units of measurement) about
how the motion controller will operate and interpret data.

• Communication:  displays configuration information for data transfer through
the motion controller’s serial port.

• Axis:  contains information about how the axes operate in your application.
Click the appropriate Axis button to view data for each axis in your system.
This tab also allows you to add or delete axes.

• Coordinate:  provides reference coordinate information.

• Travel: Allows you to set parameters for software travel limits.

• Velocity:  shows the feedrate velocity for each axis.

• Acc/Dec:  displays acceleration and deceleration mode and duration data.

• Servo:  allows you to define operation for each servo. Click the appropriate
Axis button to view servo-related information for each servo in your system.

• DI/DO:   allows you to enable digital input and output signals for the motion
controller.

• Spindle:  configures spindle operation for the Power Mate D.

• Compensation:  specifies tool compensation for your motion control
application.

• Cycles:  contains information about spindle direction and drilling axis for the
Power Mate D.

• Macros:  allows you to initialize G codes and M codes for custom macros and
subprograms.

• Panel:  allows you to specify settings for the software operator’s panel.
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Using the List Window

The List window displays parameters by number, shows parameter status, and
allows you to change a parameter’s value.

To access the List window:

• Go to the View menu and choose ByList or

• Click the View Parameter List toolbar button .

Figure 2-6.  List window
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Viewing Parameter Details

To view information about a specific parameter, double-click the parameter number.
A QuickHelp dialog box will appear providing details about the selected parameter.

Figure 2-7.  QuickHelp dialog box

Changing Parameter Values

To change a parameter’s value from the List window, do the following:

1. Highlight the parameter’s value.

2. Begin typing the value you want. The numbers you type will appear in the
Input field at the bottom of the screen. Be sure to include all bits of the
parameter. To cancel the procedure, press ESC.

3. Press ENTER. The parameter list will update with the new value.
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Starting Work with the Motion Programmer

CIMPLICITY Motion Programmer allows users to create motion profiles
(programs) for GE Fanuc’s Power Mate H, Motion Mate APM300 Series, Motion
Mate DSM300 Series, and Motion Mate MCS700 Series motion controllers. The
Motion Programmer and Motion Configurator are separate programs but can
complement each other:  a configuration edition from the Configurator and a
motion profile from the Programmer that share the same project folder and target
controller will share the same configuration database.

After the CIMPLICITY Motion Programmer is started, a new window called
“Profile1” is displayed.  This window will be used to create the motion profile.  The
two required components of every motion program—Start and End—automatically
appear on the screen.

Note
If your profile is targeting a two-axis Motion Mate APM300
Series or a two-axis Motion Mate DSM300 Series, a profile
window will be displayed for each axis.

All files related to a project are contained in a project folder; these files include the
main profile, any subroutines it calls, any user-defined components, and profile
configuration data.  The default project folder is called “profile” and is located in
the directory where CIMPLICITY Motion Programmer was installed.

Chapter Contents
This chapter provides the following information:

• Creating and opening a motion profile

• Overview of the motion profile window

• Creating and setting a project folder

• Motion profile save options

• Backing up and restoring profiles

• Customizing the window display

• Motion profile toolbars

Chapter

3
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Creating and Opening Motion Profiles

You can create a new motion profile or open an existing motion profile through the
menu bar or toolbar buttons.

To Create a New Motion Profile:

When CIMPLICITY  Motion is started, a new profile will automatically appear. A
new profile displays the start and end components in the profile editor window.
You can also create a new profile by

• clicking the New toolbar button  or

• selecting the File menu and choosing New.

You can have more than one profile open at the same time.

Note

If you want to create a new profile targeting a different controller,
you must first change the project folder by going to the File
command and choosing Set Folder. If a different folder is selected,
the folder name will appear in the status bar when the profile is
saved.
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To Open an Existing Motion Profile:

1. Click the Open toolbar button  or select the File menu and choose Open.
The Open dialog box will appear:

Figure 3-1.  The Open dialog box

2. Click the arrow beside the Look In field then click on the drive or folder that
contains the profile.

3. In the box beneath the Look In field, double-click the name of the folder that
contains the profile.  Continue double-clicking folders until you reach your
profile’s name.

4. Click the profile’s name then click the Open button.

Shortcut
To open one of the last profiles you worked on, select the File menu and choose the
filename from the numbered list located above the Exit selection.

To control whether this list appears and how many entries it contains:

1. Select the Tools menu and choose Options.

2. Select the Edit tab.

3. Click the Recently Used File List check box to toggle the option on or off.  In
the Entries field, select the number of filename entries you want to appear in
the list.

4. Click the OK button.  If you have changed the number of filename entries, you
must exit and restart before the new number will take effect.
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The Motion Profile Window

Click a button to add a new component to your motion
profile.

COMPONENT TOOLBAR
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Use this window to create your motion profile.
Double-click a component to configure its operating
parameters.

PROFILE WINDOW

STATUS BAR
Specifies the path of the current project folder.

Specifies the target controller
for the current motion profile.

Tells whether the current
motion profile is valid.

Start component End component

Figure 3-2.  Motion Profile Window
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Using the Mouse

The mouse is used to choose components as well as place, move, and link
components in the profile window.

For all operations requiring a mouse button, use the left mouse button unless
otherwise noted.

Mouse Icons

CIMPLICITY Motion uses several different icons to represent the location of the
mouse or indicate the operation that is being performed or can be performed.

The following table lists the mouse cursor icons used in CIMPLICITY Motion:

Table 3-1.  Motion Profile Window Mouse Icons

Icon Location Meaning
Over non-component
objects

Pointing, selecting, or
moving

Anywhere in window The application is waiting
for a process to complete

Over an edge or corner of a
window

Resizing a window

Over any object Operation is not allowed

Over a profile component Selecting or moving the
component

Over the output handle of a
component

Can perform a connection
operation

Over the input handle of a
component

Can perform a connection

Over non-component
objects

Currently in connection
mode looking for an output
handle

Over non-component
objects

Currently in connection
mode looking for an input
handle

Over the output handle of a
connected component

Can break the connection
between the components
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Creating and Setting Project Folders

The main profile, all of its subroutines, any user-defined components, and its
configuration data are stored in a project folder.  The default project folder is called
“profile” and resides in the folder where the CIMPLICITY Motion Programmer was
installed.  You can change the location of the existing folder, create a new folder, or
designate a new target controller for the folder.

If you used CIMPLICITY Motion Configurator to set up your controller’s
parameters, you may want to store your motion profile information in the same
project folder as the configuration edition you are using. This gives the Motion
Programmer access to the configuration information you have already specified and
may save you time in entering some of the configuration data required for your
motion profile.

Note

The configuration database will use only the active version of the
configuration data file.  If you have saved several versions of the
configuration data file, verify that the active version is current for
your configuration.

Creating a New Project Folder

To create a new project folder:

1. Select the File menu and choose Set Folder.

2. Specify where you want the new folder located by choosing the drive and
double-clicking the folder in which you want your project folder to be stored.

3. Click the Create Folder button.  The New Folder dialog box will appear.

Figure 3-3.  The New Folder Dialog Box

4. Type the name of the new folder in the field.

5. Click the OK button.  The Configure Folder dialog box will appear.
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Figure 3-4.  The Configure Folder Dialog Box

6. Click the drop-down arrow beside the Target for Folder field and choose a
target controller from the list. Only APM300, Power Mate H, MCS700, and
DSM300 are valid choices for release 2.0 of CIMPLICITY Motion
Programmer.

7. Click the arrows in the Number of Axes field to specify the number of axes on
the machine.

8. Click the OK button.

Changing the Project Folder’s Location

To change the location of the current project folder:

1. Select the File menu and choose Set Folder. The Set Folder dialog box will
appear:

Figure 3-5.  The Set Folder dialog box

2. Under Drives, click the drop-down arrow to choose the drive you want your
project folder stored on.  If the drive you want does not appear in the list, click
the Network button and fill in the Map Network Drive dialog box.
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3. In the Directories box, double-click the folder in which you want your project
folder to be stored.

4. Click the OK button.  The Configure Folder dialog box will appear.

5. Click the drop-down arrow beside the Target for Folder field and choose a
target controller from the list. Only APM300, Power Mate H, MCS700, and
DSM300 are valid choices for release 2.0 of CIMPLICITY Motion
Programmer.

6. Click the arrows in the Number of Axes field to specify the number of axes on
the machine.

7. Click the OK button.

Designating a New Target Controller for a Folder

You can change the default target system through the Edit tab of the Options dialog
box; however, this area does not allow you to change the number of axes on the
machine.

To change both the target controller and the number of axes for a folder, you must
change the name or location of the folder.  After you have completed moving or
renaming the folder, the Configure Folder dialog box will automatically appear.

1. Click the drop-down arrow beside the Target for Folder field and choose a
target controller from the list. Only APM300, Power Mate H, MCS700, and
DSM300 are valid choices for release 2.0 of CIMPLICITY Motion
Programmer.

2. Click the arrows in the Number of Axes field to specify the number of axes on
the machine.

3. Click the OK button.

Save Options

This section tells how to save, rename, backup, and restore your motion profile.

Saving the Motion Profile

To save a profile:

• click the Save toolbar button  or

• select the File menu and choose Save.

To save all open profiles, select the File menu and choose Save All.
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When you save a profile for the first time, the Save As dialog box will appear to
allow you to name your profile.  The Motion Programmer will automatically attach
the .PFL filename extension to your profile’s name.

Save Options

The Motion Programmer allows you to set default save options related to whether a
backup file is made when your profile is saved and whether your profile is saved
automatically while you are working on it.

Automatic Backup Option

When this option is turned on, the Motion Programmer automatically creates a
backup copy of the currently selected profile during the save operation.  This file
will have the .BAK filename extension.  The default of this option is on.

To turn this option on or off:

1. Select the Tools menu and choose Options.

2. Select the Save tab.

3. Click the Always Create Backup on Save check box to toggle the option on or
off.

Automatic Save Option

When this option is turned on, the Motion Programmer automatically saves a
temporary copy of the currently selected profile as often as you specify.  The default
of this option is on, saving every ten minutes.

Profiles that are saved automatically are stored in the location specified in the File
Locations tab of the Options dialog box until you save them through the Save or
Save As commands. When you restart the Motion Programmer after a power failure
or other problem that occurred before you saved your work, the automatically saved
profile is opened so you can save it normally.

To turn this option on or off:

1. Select the Tools menu and choose Options.

2. Select the Save tab.

3. Click the Automatic Save Every check box to toggle the option on or off.

4. In the Minutes field, select how often you want your files automatically saved.
Valid automatic save times range from 1 to 120 minutes.
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Renaming the Motion Profile
To save your Motion profile under another name, select the File menu and choose
Save As.  In the Save As dialog box, type in the new name in the Type field and the
subdirectory name in the Subdirectory field (optional).

To rename a profile:

1. Select the File menu and choose Save As.

2. If you want to save the profile in a different location, click the arrow beside the
Save In field then click on the drive or folder where you want the profile
located.  In the box below the Look In field, double-click the name of the folder
where you want your profile located.  Continue double-clicking folders until
you reach the one you want.

3. Type the profile’s new name in the File Name field.

4. Click the Save button.  The Motion Programmer will automatically attach the
.PFL filename extension to your profile’s name.

Backing Up and Restoring Motion Profiles

The Backup option allows you to create a single file containing a condensed version
of all files in a selected folder.  The Restore option restores the contents of a folder
from the condensed backup file. The currently open motion profile(s) will be backed
up only if they are part of the folder you select.

To Back Up a Folder:

1. Go to the File menu and choose Backup. The Backup Folder dialog box will
appear:

Figure 3-6.  The Backup Folder dialog box
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2. Under Drives, click the drop-down arrow to choose the drive where the project
folder you want to back up is located.  If the drive you want does not appear in
the list, click the Network button and fill in the Map Network Drive dialog box.

3. In the Directories box, select the folder you want to back up and click the OK
button. The Save Library As dialog box will appear.

4. Click the drop-down arrow beside Save In and choose where you want the
backup file to be saved.  Type the name you want for the file in the File Name
field.

5. Click the Save button. The Motion Programmer will automatically attach the
.ZIP filename extension to the backed up file’s name.

To Restore a Folder:

1. Go to the File menu and choose Restore. The Restore dialog box will appear:

Figure 3-7.  The Restore dialog box

2. Click the drop-down arrow beside Look In to choose where the backup file is
stored.

3. Click the name of the backed up file and click the Open button. The Restore
Folder To dialog box will appear.
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4. Under Drives, click the drop-down arrow to choose the drive where you want
the restored folder to be located.  If the drive you want does not appear in the
list, click the Network button and fill in the Map Network Drive dialog box.

5. In the Directories box, select the folder where you want the restored folder to be
located. If you want to create a new folder, click the Create Folder button and
type the name you want for the folder in the New Folder dialog box. Click the
OK button.

Closing the Motion Profile

To close a profile, select the File menu and choose Close.

If you have made changes to the motions profile without saving, you will be
prompted to save changes when closing the motion profile.
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Customizing the Window Display
To move a profile window, click its title bar then drag the window to its new
location.  You can also resize profile windows and neatly arrange multiple profile
windows.

Resizing The Window

The profile window can be resized in the following ways:

• Click the Maximize button  to make the window fill the screen.

• Move the mouse pointer to the edge of the window.  When the pointer change
into a two-sided arrow, click and drag the window to the desired size and
shape.

• If the screen is already maximized, click the Restore button  to restore the
window to its previous smaller size.

• Click the Minimize button  to reduce the window to a button on the
Windows 95 taskbar.

Arranging Multiple Windows

When more than one profile window is open, you can move the windows around the
screen manually or use the Cascade or Tile options provided in the Window menu.

Cascade

The cascade option arranges windows so they overlap.  The title bar of each window
is visible.  To cascade profile windows, select the Window menu and choose
Cascade.

Tile

The tile option sizes windows so they all fit on the screen without overlapping.  To
tile profile windows, select the Window menu and choose Tile.

Displaying or Hiding the Status Bar Options

The status bar located at the bottom of the screen provides helpful information about
toolbar buttons and menu selections, specifies the target controller for the current
profile, indicates whether the profile is valid, and gives the number of dangling
components (components not connected to the profile) in the profile window.

To toggle the display of the status bar on or off, select the View menu and choose
Status Bar.  As a default, the status bar is displayed.
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Motion Profile Toolbars

CIMPLICITY Motion comes with two toolbars:  Standard and Component.  The
Standard toolbar offers shortcuts to commonly used operations such as Save and
Print.  The Component toolbar contains the components used to create a motion
profile.

You can also produce toolbars containing user-defined components (UDCs) you
have created. To create a custom UDC toolbar, go to the Tools menu and choose
Create Library.

To quickly find out what a specific toolbar button does, move the mouse cursor over
the button.  A small box will appear below the mouse cursor telling the button’s
name and the status bar in the lower left-hand corner of the screen will provide a
brief description of the button’s use.

Displaying or Hiding Toolbars

The default setting is to display both the Standard and Component toolbars.  You
choose to hide either toolbars. To display or hide a toolbar:

1. Select the View menu and choose Toolbars.

2. In the Toolbars dialog box, click the check box beside Standard or Component
to toggle the toolbar’s display on or off.  Click the OK button.
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Figure 3-9.  The Component toolbar

Note

The active toolbar buttons may vary, depending on the target
controller and number of axes configured for your motion profile.
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Moving Toolbars

To move one of the toolbars to a different location on the screen, click and hold the
toolbar in on an area not covered by a button then drag the toolbar to its new
location.
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Using the Motion Profile Editor

The motion profile window is the work area for creating a motion profile.  When
you create a new profile, the window appears containing the motion profile’s Start
and End components.  You create a motion profile by adding other components to
the window, defining each component’s parameters, then linking the components
together in the sequence they will execute in the target motion controller.

Chapter Contents

This chapter provides the following information:

• Creating and editing the motion profile

• Understanding the motion profile components

• Printing the motion profile

Chapter

4
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Creating the Motion Program

Each component represents a step in the motion program.  The way the components
are connected determines the sequence in which the motion application will
execute.

To create the graphical representation of a profile, you must follow these steps:

1. Choose the components you want as part of your profile and place them in the
profile window.

2. Define the appropriate data for each component.

3. Connect the components to indicate the motion profile’s sequence.

This section describes how to work with components and set the configuration
parameters for your application.

Setting Configuration Parameters

You can set basic configuration parameters for your application (for Power Mate H
and Motion Mate MCS700 Series controllers only) using CIMPLICITY Motion
Configurator or you can set parameters from within CIMPLICITY Motion
Programmer.

To Set Parameters Using CIMPLICITY Motion Configurator

If you are also using CIMPLICITY Motion Configurator, you can automatically
access the settings from a specific configuration edition (and eliminate the need to
specify them within the Motion Programmer). To access configuration information
from the Motion Configurator, do the following:

• Before you exit CIMPLICITY Motion Configurator, be sure that the edition
whose data you want the Motion Programmer to access is the active edition (an
arrow will appear beside it). The edition that was active before the Motion
Configurator was closed will remain the active edition for that project folder.

• Set your Motion Programmer folder to the folder where the configuration
edition you want is located. When motion profile and configuration edition
share the same project folder, the Motion Programmer and Motion
Configurator share the same configuration database.

• Confirm that the edition and the motion profile target the same controller and
are being used for the same motion application.
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To Set Parameters Within CIMPLICITY Motion Programmer

It is recommended that you set configuration parameters (such as units of
measurement and axis labels) before you begin creating your profile, although you
may set these parameters at any time.

To set configuration parameters for the Power Mate H or Motion Mate
MCS700 Series:

1. Select the Target menu and choose Configuration.

2. Click the tab corresponding to the parameters you want to set.

• General:  Allows you to specify axis position input units and the least
command increment, set the cycle counter, and indicate the maximum
allowable machine velocity.

• Axis Data:  Allows you to assign labels to the axes, specify whether each
axis is linear or rotary, and assign axis travel limits.

• More Axis Data:  Allows you to select an acceleration mode and time and
specify a current override value for each axis.

• Auxiliary Actions Tab:   Allows you to specify any actions that may take
place external to the profile.

3. After you have edited the desired parameters, click the OK button.

To set configuration parameters for the Motion Mate APM300 or Motion
Mate DSM300Series:

1. Select the Target menu and choose Configuration.

2. Click the tab corresponding to the parameters you want to set.

• Configuration:  Allows you to select units and target memory.

• Control Bits:   Allows you to assign names to control bits.

3. After you have edited the desired parameters, click the OK button.
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Working with Components

Each component represents specific action in the motion profile and is represented
in the profile window by a square icon. Components contain one or more input and
output handles.  These handles serve as connection points to join one component to
another.

A red slash through a component indicates that the
component is invalid and its parameters must be defined.
If any components in the motion profile are invalid then
the whole profile is marked invalid and cannot be
downloaded to the motion controller.

Inserting a Component

You can add components to the profile window using the buttons on the Component
toolbar or the selections on the Insert menu.

Using the Component Toolbar

1. Click the toolbar button corresponding to the component you want to add to the
window.  The component’s icon will be attached to the crosshair mouse cursor.

2. Move the mouse cursor to the location you want to place the component.

3. Click the left mouse button.

Using the Insert Menu

1. Select the Insert menu and choose the name of the component you want to add
to the window.  The component’s icon will be attached to the crosshair mouse
cursor.

2. Move the mouse cursor to the location you want to place the component.

3. Click the left mouse button.

Selecting Components in the Profile Window

Some operations, such as Copy or Delete, require you to select a component in the
profile window.

To select a component, click it with the left mouse button.  The selected component
will look like a pressed-in button with a black frame around it.

Input handle

Output handle
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To select more than one component at a time, hold down the left mouse button and
drag the mouse over the components you want to select. A square will appear
around the selected components.

Moving Components

To move a component, select the component and drag it to the desired position.  To
move several components, select the components by drawing a box around them and
drag the box to the desired position. You cannot allow components to overlap or be
placed outside of the profile window.

If the component is connected to another component, moving the component will
cause the connection line to be redrawn.

If you place a component over a connection line, the connection line will be
modified so that it does not run through the component.

Deleting Components

To delete a component, select the component and press the Delete key or select the
Edit menu and choose Delete.  To delete several components, select the components
by drawing a box around them and press the Delete key or select the Edit menu and
choose Delete.

If the component is connected to another component, the connections between the
two will automatically be deleted.

Neither the Start nor End components can be deleted.

Editing Components

CIMPLICITY Motion supports standard Windows editing commands. You can
access these commands through the Edit menu or by using standard Windows
keyboard shortcuts. In addition, the Delete and Copy commands are provided on the
right mouse button pop-up menu (when a component is selected, click the right
mouse button).

Cut, Copy, and Paste

You can use standard Windows Cut, Copy, and Paste commands on components in
the active profile, or between different profiles.  When you cut or copy a component
then paste it, the pasted component retains the same component data as the original
component.
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To cut, copy, or paste a component, select the component and click the appropriate
button from the Standard toolbar or select the Edit menu and choose the appropriate
selection.  To cut, copy or paste several components, select the components by
drawing a box around them and then perform the desired operation.

Neither the Start nor End components can be cut, copied, or pasted.

Duplicate

The Duplicate command copies a selected portion of the profile then attaches that
selection to the mouse cursor so it can be pasted where you choose in the profile.

To duplicate part of your profile, do the following:

1. Hold down the left mouse button and drag the mouse over the components you
want to select. A square will appear around the selected components.

2. Go to the Edit menu and choose Duplicate. A copy of the selected components
will appear on the mouse cursor crosshairs.

3. Move the mouse cursor to the location you want and click the left mouse
button.

Neither the Start nor End components can be duplicated.

Defining Component Data   

A component is considered invalid (indicated by a red diagonal slash through it)
until its parameters have been defined.

To define a component’s data, double-click the component icon in the profile
window or select the component, click the right mouse button, and choose
Associated Data from the menu.  A dialog box specific to that component will
appear.  If you need help understanding the fields in any of the dialog boxes, press
the Help button in the box.

Figure 4-1.  Example of a Component Data dialog box

All component dialog boxes contain an optional Comment field.  If you include a
comment for a component, you will be able to view that comment in the status bar
when the mouse cursor moves over that component.
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When a dialog box field calls for a numeric value, you have the option of entering
either the actual value or a register reference.  A register reference allows you to
assign an alphanumeric name to a reference location.

Assigning Register References (Power Mate H and Motion Mate MSC700
Series)

Before you can use a register variable name in a dialog box field, you must first
assign the name to a register.  Register locations are available for classifications
such as timers, counters, and alarms.

To assign a variable name to a register location:

1. Select the Target menu and choose Registers. The Registers dialog box will
appear:

Figure 4-2.  The Registers dialog box

2. In the Registers dialog box, click the tab corresponding to the register
classification you want.

3. Double click the register number.  A field will appear in the Variable column to
allow you to type the name you want.  The maximum length of the variable
name is 31 characters and can be any combination of letters, numbers, or
symbols.  The first character of the variable must be a letter.

4. Click the OK button.



4-8 Using CIMPLICITY Motion  – November 1997 GFK-1362A

4

The following table shows the register reference assignments:

Table 4-1.  Register References

Group Range Description

Local 1 – 33 Holds data such as the result of a mathematical operation.  When power is
cycled on the control, all local variables are initialized to null.

Common 100 – 199
500 – 699

Common variables can be shared among different profiles.  When power
is cycled on the control, variables 100 to 199 are initialized to null.
Variables 500 to 531 retain their data even when power is cycled.

Input 1000 – 1133 Input variables are system variables that allow interface signals to be
exchanged between the controller and the register.

• Variables 1000 through 1015 read bit-by-bit a 16-bit signal sent by
the controller; variable 1032 reads all 16 bits of the signal at one time.

• Variables 1100 through 1115 write bit-by-bit a 16-bit signal sent to
the controller; variable 1132 writes all 32 bits of the signal at one
time.

• Variable 1133 writes to the controller all 32 bits of a 32-bit signal at
one time (valid values range from -99999999 to +99999999)

Timer 1200 – 1224 Timer variables allow you to set variable timers that can be read by or
written to a profile instruction.  These variables retain their value when
power is cycled on the control.

Counter 1225 – 1244 Counter variables can be read by or written to a profile instruction.  These
variables retain their value when power is cycled on the control.

Data 1245 – 1709 Data variables can be used for sequence control by the PMC.  These
variables retain their value when power is cycled on the control.

Relay 1710 – 1959 Relay variables are used for parameters, keep relays, and other items
related to sequence control.  These variables retain their value when
power is cycled on the control.

Alarm 3000 The alarm variable is a system variable that causes the control to stop and
an alarm message to be displayed whenever a value from 0 to 200 is
assigned to the variable.

Clock 3001 – 3002 The Clock variables allow time information to be both read by and written
to the control.

• Variable 3001 functions as a timer that counts in 1-millisecond
increments.  When power is cycled on the control, the value of the
variable resets to 0.  The variable also resets to 0 when 65535
milliseconds is reached.

• Variable 3002 functions as a timer that counts in 1-hour increments
whenever the cycle start light is on.  This variable retains its value
even after power has been cycled on the control.

Units 3901 This read-only variable provides the completed number of machined parts.

Machine 5021 – 5022 These read-only variables provide information on the machine’s current
position using the machine coordinate system.

Work
Piece

5041 – 5042 These read-only variables provide information on the machine’s current
position using the workpiece coordinate system.

Skip 5061 – 5062 These read-only variables provide information on the skip signal position
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Assigning Parameter Names (Motion Mate APM300 Series and Motion Mate
DSM300 Series)

To assign a variable name to a parameter:

1. Select the Target menu and choose Registers. The Registers dialog box will
appear:

2. Double-click the parameter number. A field will appear in the Variable Name
column to allow you to type the name you want. The maximum length of the
variable name is 31 characters and can be any combination of letters, numbers,
or symbols. The first character of the variable must be a letter.

3. Click the OK button.

Connecting Components

The order in which you connect components determines the sequence of execution
in the motion profile.  Components are connected by their handles, with the output
handle of one component connecting to the input handle of another.

Manually Connecting Components

You can begin your connection at either the input or output handle.  To cancel a
connection before it is complete, click in any empty white space in the profile
window.
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To manually connect one component to another:

1. Move the mouse cursor over the input or output handle or the component.  The
mouse cursor will change into an icon of a solid plug indicating that you can
begin a connection .

2. Click the left mouse button.  The mouse cursor will change into an icon of a
hollow plug indicating that a connection is in progress .

3. Move the cursor over the input or output handle of another component.  (Note
that input handles can only connect to output handles and vice versa.)  The
mouse cursor will once again change into an icon of a solid plug .

4. Click the left mouse button.  A connection line will appear between the two
components.

Automatically Connecting Components

When turned on, the Autoconnect option automatically connects a new component
added to the profile window to the currently selected component.  The new
component then becomes selected.

The Autoconnect option is useful when you plan to add components to the profile
window in the sequence they will appear in the profile.

To turn on or off the Autoconnect option:

1. Select the Tools menu and choose Options.

2. In the Options dialog box, click the Edit tab.

3. Click the Automatically Connect New Components check box to toggle the
option on or off.

Disconnecting Components

To break the connection between two components:

1. Move the mouse cursor over the output handle of a currently connected
component.  The mouse cursor will change into an icon of a pair of scissors
indicating that the connection can be broken.

2. Click the left mouse button.  The connection line will disappear.

Setting Profile Size

While there is no limit to the number of components allowed in a profile, you can
specify a fixed maximum height and width of your profile.  The values for these
limits is the number of components permitted.
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When the entire profile cannot be displayed on the screen, you can use the vertical
and horizontal scroll bars to scroll to other areas of the profile.

To set the default profile size:

1. Select the Tools menu and choose Options.

2. In the Options dialog box, click the Edit tab.

3. In the Maximum Profile Size area, specify the maximum values (measured by
the number of components) for height and width.

4. Click the OK button.

Using Dangling Components

Dangling components are components that are not connected between the Start and
End component.  Dangling components can be useful to your profile.  For example,
you can use the Text component to enter helpful information about the profile.  The
status bar indicates the number of dangling components in the profile window.

A profile can still be valid if it has dangling components.  However, when the
profile is downloaded to the control, only those components connected between the
Start and End components will be transferred, and a warning may be issued
signaling that there are dangling components.
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Component Details

This section provides a brief explanation of each standard component as well as
information about the fields in the component’s associated data dialog box. See
Chapter 5, “Creating Custom Components,” for information about creating user-
defined components.

The associated data dialog boxes for all of the components contain an optional
comment field, which allows you to type an alphanumeric comment about the
component.  If you include a comment for a component, you will be able to view that
comment in the status bar when the mouse cursor moves over the component.  For the
Power Mate H and Motion Mate MCS700, comments will be transferred to the
controller.

Start Component  
The Start component automatically appears in the profile window at the creation of
a new profile and indicates the beginning of the profile.  Each profile has only one
Start component.  This component cannot be copied or deleted from the profile.

The component is invalid until you specify its Profile ID.  To specify the ID and other
parameters, double-click the Start component.  The Start Component Data dialog box
allows you to set the Profile ID, the positioning mode, and the units of measurement
for velocity.  You can also indicate whether the current profile is a subroutine.

Profile IDs must be unique within a folder. CIMPLICITY Motion will display ID
numbers that may be used for new profile IDs.

Associated Data: Power Mate H and Motion Mate MCS700

Figure 4-3.  Start Component Data dialog box for Power Mate H and Motion Mate
MCS700
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Profile ID

The Start component is invalid until the Profile ID has been specified.

Use the drop-down arrow to select a numerical ID for the current profile.  Valid ID
numbers for the Power Mate H and Motion Mate MCS700 range from 1 to 400.
Valid ID numbers for the DSM300 and APM300 range from 1 to 10.  IDs must be
unique for each profile in a project folder (only unused IDs will be displayed).  If
this profile is a subroutine, the main profile will use this ID number to call the
profile. IDs for subroutines may range from 1 to 40.

If the current profile is a subroutine, click the Subroutine check box.

Positioning mode

This area allows you to set the initial positioning mode as absolute or incremental.
This value defaults to the value specified in the Edit tab of the Options dialog box.

Units

This area allows you to specify the units for velocity values that appear in
CIMPLICITY Motion.  This value defaults to the value specified in the Edit tab of
the Options dialog box.

Associated Data: Motion Mate APM300 and Motion Mate DSM300

Figure 4-4.  Start Component Data dialog box for Motion Mate APM300 and Motion
Mate DSM300
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Profile ID

The Start component is invalid until the Profile ID has been specified.

Use the drop-down arrow to select a numerical ID for the current profile.  Valid ID
numbers for the Power Mate H and Motion Mate MCS700 range from 1 to 400.
Valid ID numbers for the DSM300 and APM300 range from 1 to 10.  IDs must be
unique for each profile in a project folder (only unused IDs will be displayed).  If
this profile is a subroutine, the main profile will use this ID number to call the
profile. IDs for subroutines may range from 1 to 40.

If the current profile is a subroutine, click the Subroutine check box.

Positioning mode

This area allows you to set the initial positioning mode as absolute or incremental.
This value defaults to the value specified in the Edit tab of the Options dialog box.

Axis selection

Choose whether the selected axis is axis 1 or 2.

Acceleration Mode

Choose between Linear and S-curve.

End Component  

The End component automatically appears in the profile window at the creation of a
new profile and indicates the end of the profile.  Each profile has only one End
component.  This component cannot be copied or deleted from the profile.

There are no parameters that have to be set for the End component.  If you want to
add a comment to the component, double-click the End component and type your
comment in the End Component Data dialog box.

Associated Data

Figure 4-5.  End Component Data dialog box
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Move Component  

The Move component initiates linear machine motion.

The component is invalid until you specify destination position data for at least one
axis.  To specify position and other motion parameters, double-click the Move
component.

A vectored move will automatically occur when you enter destination data for more
than one axis. The maximum number of axes for a vectored move is three.

Associated Data:  Power Mate H and Motion Mate MCS700

Figure 4-6.  Move Component Data dialog box for the Power Mate H and Motion Mate
MCS700

Move Type

Click the type of move you want, either positioning or continuous.  This value
defaults to the value specified in the last edited motion component.  The default
value for the first-used motion component is Positioning.
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Positioning Mode

Click Absolute or Incremental to specify whether the positioning mode of the
destination data represents absolute coordinates or incremental offsets.  This value
defaults to the value specified in the Start component.

Velocity Units

This area allows you to specify the units in which velocity is measured.  Choose
between distance units per minute or distance units per revolution.

In the Velocity field, type the velocity at which you want the motion to take place.
This value defaults to the value specified in the last edited motion component.  The
default for the first-used motion component is zero.

Destination Data

Enter the destination position for each axis.  If you do not supply a value for an
axis, that axis will not be commanded to move.  The Move component is invalid
until at least one axis destination is specified.

Associated Data:  Motion Mate APM300 and Motion Mate DSM300

Figure 4-7.  Move Component Data dialog box for the Motion Mate APM300 and Motion
Mate DSM300
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Move Type

Click the type of move you want, either positioning or continuous.  This value
defaults to the value specified in the last edited motion component.  The default
value for the first-used motion component is Positioning.

Positioning Mode

Click Absolute or Incremental to specify whether the positioning mode of the
destination data represents absolute coordinates or incremental offsets.  This value
defaults to the value specified in the Start component.

Acceleration Mode

Choose whether acceleration will proceed linearly or along an S-curve.

Velocity

Specify the velocity of axis motion (in user units/sec).

Acceleration

Specify the acceleration rate for axis motion (in user units/sec/sec).

Note

User units will vary, depending on the motion controller selected
and base (English or Metric).

Destination Data

Enter the destination position for each axis.  If you do not supply a value for an
axis, that axis will not be commanded to move.  The Move component is invalid
until at least one axis destination is specified.
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Circular Move Component  

The Circular Move component initiates circular machine motion.

The component is invalid until you specify destination position data for at least the
first two axes and the radius value.  To specify position and other motion
parameters, double-click the Circular Move component.

Circular motion occurs only in the first 2 axes displayed in the dialog box.

This component can only be used in profiles targeting the Power Mate H or Motion
Mate MCS700.

Associated Data

Figure 4-8.  Circular Move Component Data dialog box

Move Type

This area allows you to specify the direction of the circular motion, either clockwise
or counterclockwise.  This value defaults to the value specified in the last edited
Circular Move component.  The default for the first-used Circular Move component
is Clockwise Arc.
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Positioning Mode

Click Absolute or Incremental to specify whether the positioning mode of the
destination data represents absolute coordinates or incremental offsets.  This value
defaults to the value specified in the Start component.

Destination Data

Enter the destination position for each axis.  If you do not supply a value for an
axis, that axis will not be commanded to move.  The Circular Move component is
invalid until at least the first two axes and the Radius values are specified.

If the radius value is for an arc greater than 180°, click the Arc Greater Than 180°
check box.

Velocity Units

This area allows you to specify the units in which velocity is measured.  Choose
between distance units per minute or distance units per revolution.

In the Velocity field, type the velocity at which you want the motion to take place.
This value defaults to the value specified in the last edited motion component.  The
default for the first-used motion component is zero.
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Reference Point Move Component  

The Reference Point Move component initiates machine motion to the machine’s
reference position (home position).  Once there, the axes then move to the position
specified in the Reference Point Move Component dialog box.

The component is invalid until you specify intermediate position data for at least
one axis.  To specify position and other motion parameters, double-click the
Reference Point Move component.

This component can only be used in profiles targeting the Power Mate H or Motion
Mate MCS700.

Associated Data

Figure 4-9.  Reference Point Move Component Data dialog box

Positioning Mode

Click Absolute or Incremental to specify whether the positioning mode of the
intermediate point destination data represents absolute coordinates or incremental
offsets.  This value defaults to the value specified in the Start component.

Intermediate Point

Enter the intermediate destination position for each axis.  If you do not supply a
value for an axis, that axis will not be commanded to move to the intermediate
destination.  The Reference Point Move component is invalid until at least one of
the intermediate point destination values is specified.
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Execution Conditions Component  

The Execution Conditions component permanently alters (on the controller)
operating characteristics such as axis limits and control torque, acceleration, and
machine cycle.  The new parameters remain in effect until another Execution
Conditions Component is executed or the motion controller configuration is
modified.

To view and edit parameters, double-click the Execution Conditions component.
Each tab of  the dialog box controls a different set of system parameters. The
Execution Condition component is invalid until at least one parameter is edited.

This component can only be used in profiles targeting the Power Mate H or Motion
Mate MCS700.

Associated Data

Each tab of this dialog box controls a different set of system parameters.  The
Execution Condition component is invalid until at least one parameter is edited.

Note

Parameters set in this dialog box override the corresponding
parameters in the Configuration dialog box.
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Axis Travel Limits Tab

This tab allows you to set new axis travel limits.  These values default to the values
specified in the last edited Execution Conditions component.  The default values for
the first-used Executions Conditions component are taken from the Axis tab of the
Configuration dialog box.

Figure 4-10.  Execution Conditions Component Data dialog box:  Axis Travel Limits tab

Set Axis Limits

To set new axis limits, click the Set Axis Limits check box then modify the new
positive and negative travel limits for each axis you want to change.
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Torque Settings Tab

This tab allows you to specify new axis torque limits.  The original torque limit
values are specified in the More Axis Data tab of the Configuration dialog box.  The
values shown in this tab default to zero percent.

Figure 4-11.  Execution Conditions Component Data dialog box:  Torque Settings tab

Set torque control

To set new torque overrides, click the Set Torque Control check box then modify
the override percentage for each axis you want to change.
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Acceleration Tab

This tab allows you to specify new axis acceleration modes and times.  These values
default to the values specified in the last edited Execution Conditions component.
The default values for the first-used Executions Conditions component are taken
from the More Axis Data tab of the Configuration dialog box.

Figure 4-12.  Execution Conditions Component Data dialog box:  Acceleration tab

Set acceleration mode

To set new axis acceleration modes, click the Set Acceleration Mode check box then
modify the acceleration mode for each axis.  Choose among Exponential, Linear,
and Bell Shaped.

Set acceleration time

To set new axis acceleration times, click the Set Acceleration Time check box then
modify the acceleration time for each axis whose acceleration time you want to
change.  This selection is grayed unless the Set Acceleration Mode check box is
checked.

Valid values are based on the selected acceleration mode.  If the mode is Linear,
valid values range from 0 to 512.  If the mode is Exponential or Bell shaped, valid
values range from 0 to 4000.



GFK-1362A Chapter 4  Using the Motion Profile Editor 4-25

4

Cycles Tab

This tab allows you to specify the number of cycles to run.  These values default to
the values specified in the last edited Execution Conditions component.  The default
values for the first-used Executions Conditions component are taken from the
General tab of the Configuration dialog box.

Figure 4-13.  Execution Conditions Component Data dialog box:  Cycles tab

Set number of cycles to run

To set a new number of cycles, click the Set Number of Cycles to Run check box
then type the required and current number of cycles in the fields provided.  Valid
values range from 0 to 999999999.
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Coordinate Position Component  

The Coordinate Condition component sets the current position to the values
specified in the Coordinate Position Component dialog box.  This action changes
the coordinate origin position.

To specify position and other parameters, double-click the Coordinate Position
component.  The dialog box allows you to specify a new coordinate system origin by
specifying a machine position.  The Coordinate Position component is invalid until
at least one axis value is specified.

This component can only be used in profiles targeting the Power Mate H or Motion
Mate MCS700.

Associated Data

Figure 4-14.  Coordinate Position Component Data dialog box

New coordinate position

Type the axis positions you want to use to set a new coordinate system origin.
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Conditional Jump Component  

The Conditional Jump component indicates a fork in the execution sequence of the
profile.  This component allows you to specify a condition that must be tested to
determine which branch of the profile is to be followed.

Since there are two possible branches for the Conditional Jump component, it has
an extra output handle on the bottom of the component.  This extra handle is called
the trigger handle and represents the branch taken if the condition is true.  The
output handle on the right side of the component represents the branch taken if the
condition is false.

The trigger handle can be connected to any component in the profile (including
itself) in order to create a looping structure.

The component is invalid until you specify the condition.  To specify the condition,
double-click the Conditional Jump component.  The profile is invalid until both
output handles on the Conditional Jump component are connected to other valid
handles.

This component can only be used in profiles targeting the Power Mate H, Motion
Mate MCS700, one-axis Motion Mate APM300, or one-axis Motion Mate DSM300
controllers.

Path taken if condition is false

Path taken if condition is true
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Associated Data:  Power Mate H and Motion Mate MCS700

This dialog box allows you to specify a condition to be tested that will determine
which branch of the profile will be followed.

Figure 4-15.  Conditional Jump Component Data dialog box:  Power Mate H and Motion
Mate MCS700

Condition

These fields specify the condition to be tested.  The first and last fields are used for
the expressions to be compared and the middle field contains the comparison
operator.

In the two expression fields you can type a numeric value or a register variable
name.  Register variable names are created in the Registers tab of the Configuration
dialog box.  If you type a new variable name into an expression field, you will be
prompted to define the variable before continuing.

The comparison operator indicates how the expressions will be compared.  Choose
one of the following symbols from the drop-down list:

= equal

<> not equal

> greater than

< less than

>= greater than or equal to

<= less than or equal to

The default setting is =.
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Associated Data:  Motion Mate APM300 and Motion Mate DSM300

This dialog box allows you to specify a condition to be tested that will determine
which branch of the profile will be followed. The jump will occur when the
condition tests true. The Conditional Jump component is invalid until a valid
condition is specified.

Figure 4-16.  Conditional Jump Component Data dialog box:  Motion Mate APM300 and
Motion Mate DSM300

Condition

Click the drop-down arrow and choose a control from the list. To associate a trigger
input with a CTL number, go to the Target menu, choose Configuration, and click
the Control Bits tab of the Configuration dialog box.
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While/End While Component    
The While component allows you to specify a condition to be checked or monitored
during the execution of a set of components.

For profiles targeting the Power Mate H or Motion Mate MCS700 Series, the
specified condition is checked at the beginning of the logic loop each time the logic
is performed.

For profiles targeting a one-axis Motion Mate APM300 Series or Motion Mate
DSM300 Series, if the condition being monitored triggers while the specified
components are being executed, the remaining components in the set are skipped
and execution resumes at a trigger destination within the profile.

The While component is invalid until the condition to be monitored is specified in
the While Component Data dialog box. The While component must also be
connected to an End While component through the While component’s output
handle and have a complete path from its trigger destination handle to the mainline
path of the motion profile.

The While component cannot be used in profiles targeting a two-axis Motion Mate
APM300 Series or two-axis Motion Mate DSM300 Series.

Associated Data:  Power Mate H and Motion Mate MCS700

This dialog box allows you to specify a condition to be monitored during the
execution of a set of components.  The End While Component Data dialog box
contains only an optional comment field.

Figure 4-17.  While Component Data dialog box:  Power Mate H and Motion Mate
MCS700

Condition

These fields specify the condition to be monitored.  The first and last fields are used
for the expressions to be compared and the middle field contains the comparison
operator.
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In the two expression fields you can type a numeric value or a register variable
name.  Register variable names are created in the Registers tab of the Configuration
dialog box.  If you type a new variable name into an expression field, you will be
prompted to define the variable before continuing.

The comparison operator indicates how the expressions will be compared.  Choose
one of the following symbols from the drop-down list:

= equal

<> not equal

> greater than

< less than

>= greater than or equal to

<= less than or equal to

The default setting is =.

Associated Data:  Motion Mate APM300 and Motion Mate DSM300

This dialog box allows you to specify a condition to be monitored during the
execution of a set of components. The End While Component Data dialog box
contains only an optional comment field.

Figure 4-18.  While Component Data dialog box:  Motion Mate APM300 and Motion
Mate DSM300

Condition

Click the drop-down arrow and choose a control from the list. To associate a trigger
input with a CTL number, go to the Target menu, choose Configuration, and click
the Control Bits tab of the Configuration dialog box.
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Wait Component  

The Wait component initiates a delay into the execution of the motion profile.

The component is invalid until you specify the amount of time for the delay.  To
specify the delay time, double-click the Wait component.

Associated Data:  Power Mate H and Motion Mate MCS700

Allows you to specify the duration of the delay in the profile.  The wait time value
defaults to the value specified in the last edited Wait component.  The default value
for the first-used Wait component is 0.  The Wait component is invalid until you
specify a valid delay time.

Figure 4-19.  Wait Component Data dialog box:  Power Mate H and Motion Mate
MCS700

Dwell Time

Type the duration of the wait, measured in milliseconds.  Valid values range from 0
to 65535.
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Associated Data:  Motion Mate APM300 and Motion Mate DSM300

This dialog box allows you to specify the duration of the delay in the profile or the
condition to wait on.  The wait time value defaults to the value specified in the last
edited Wait component.  The default value for the first-used Wait component is 0.
The Wait component is invalid until you specify either a valid delay time or a wait
condition.

Figure 4-20.  Wait Component Data dialog box:  Motion Mate APM300 and Motion Mate
DSM300

Dwell Time

Type the duration of the wait, measured in milliseconds.  Valid values range from 0
to 65535.

APM Wait Condition

Click the drop-down arrow and choose a control from the list. To associate a trigger
input with a CTL number, go to the Target menu, choose Configuration, and click
the Control Bits tab of the Configuration dialog box.
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Synchronize Component  

The Synchronize component is used to synchronize the axes in a two-axis Motion
Mate APM300 Series or Motion Mate DSM300 Series profile. When the
Synchronize component is inserted into the profile of one axis, a Synchronize
component with the same ID number is also inserted into the profile of the second
axis.

When one axis executes the Synchronize component, it waits until the other axis
executes the corresponding Synchronize component before both axes continue with
the next component in their profiles.

Figure 4-21.  Synchronize dialog box
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Subroutine Component  

The Subroutine component causes the subroutine profile specified in the Subroutine
Call Component Data dialog box to execute.  After the subroutine profile has
completed, the execution sequence continues with the component immediately
following the Subroutine component.

When you download a profile that includes Subroutine components, you must also
download the subroutine profiles.

The component is invalid until you specify the profile ID of the subroutine you want
to call.  To specify the subroutine and the number of times the routine will be
executed, double-click the Subroutine component.

Note

Motion Profiles may be called as subroutines if the Subroutine
check box is set in the Start Component for the profile.

Associated Data:  Power Mate H and Motion Mate MCS700

This dialog box allows you to specify which subroutine will be called to be run and
how many times it will be run.

Figure 4-22.  Subroutine Call Component Data Dialog Box

Call subroutine

To specify a subroutine, click the drop-down arrow and choose a Profile ID number
from the list.  The list contains only Profile IDs for valid subroutines in the current
project folder.
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If the subroutine you want to call does not yet exist, type the number you want to
use in the Call Subroutine field.  Valid values range from 0 to 400.

Repetitions

Select the number of times the subroutine’s execution should be repeated.  Valid
values range from 1 to 999.  The default value is 1.

Associated Data:  Motion Mate APM300 and Motion Mate DSM300

This dialog box allows you to specify which subroutine will be called to be run. The
Subroutine component is invalid until a subroutine profile ID is specified.

Figure 4-23.  Subroutine Call Component Data dialog box:  Motion Mate APM300 and
Motion Mate DSM300

Call subroutine

To specify a subroutine, click the drop-down arrow and choose a Subroutine ID
number from the list.  The list contains only IDs for valid subroutines in the current
project folder.

If the subroutine you want to call does not yet exist, type the number you want to
use in the Call Subroutine field.  Valid values range from 1 to 40.
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Auxiliary Actions Component  

The Auxiliary Actions component initiates the execution of an action outside of the
profile (for functions which interface through the machine's I/O).  When the
auxiliary action  has completed,  the execution sequence continues with the
component immediately following the Auxiliary Actions component.

The Auxiliary Actions component is invalid until a valid action is specified.  To
specify an auxiliary action, double-click the Auxiliary Action component.

This Auxiliary Actions component can only be used in profiles targeting the Power
Mate H or Motion Mate MCS700 controllers.

Associated Data

This dialog box allows you to specify an action outside of the profile to be called
and executed.

Figure 4-24.  Auxiliary Actions Component Data dialog box

Action

Click the drop-down arrow and choose an action from the list.  Auxiliary actions
must be specified in the Auxiliary Actions tab of the Configuration dialog box
before they can appear in the Action field.
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Text Component  
The Text component allows you to specify native language statements (RS274
language for the Power Mate H and Motion Mate MCS700; Motion Mate
APM/DSM Native Language for the Motion Mate APM300 and Motion Mate
DSM300), allowing you to create a customized action to be executed within the
sequence.  You can also use this component to place an extended comment within
the profile.

The Text component is invalid until a native language statement or comment is
entered into the scrolling region of the Text Component Data dialog box.  To access
this dialog box, double-click the Text component.  If you enter a comment into the
box, you must enclose the comment within parentheses.

For more information about native language statements, consult Appendix B,
“RS274 Language Reference,” or Appendix C, “Motion Mate APM/DSM Native
Language Reference.”

Associated Data

Allows you to type a sequence of native language statements as ASCII text.  You
can also use the component to record a long comment.

Figure 4-25.  Text Component Data dialog box
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Edit Menu

This menu provides you with access to common text editing functions such as Cut,
Copy, and Paste. You can also find or replace text and check the logic of your native
language statements through commands found in this menu.

Component Data

Type your text into this scrolling region.  You can use standard text editing features
such as copy and paste within this box.

If you are typing a comment, you must enclose the entire comment within
parentheses ( ).  The parentheses signal the control to ignore the information
contained within them.

Checking Profile Logic in the Text Component

To check the logic of  native language statements you have typed into the Text
Component Data dialog box, go to the Edit menu within the dialog box and select
Check Logic. A pop-up box will appear with the results of the logic check.
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Printing the Profile

You can include several items in your printout including the graphical profile
picture, component data, and native language statements.

Customizing the Look of the Printout

To customize features such as page size and orientation and font, go to the File
menu and choose Page Setup. From the Page Setup dialog box you can change the
following:

• Page size, orientation, and margins

• Font name, style, and size (click the Font button)

• The target printer (click the Printer button)

• The look and contents of the printout’s headers and footers (click the Header &
Footer button)

To view how the printout will look, go to the File menu and choose Print Preview.

Initiating the Print Command

To print the currently active motion profile:

1. Select the File menu and choose Print or click the Print toolbar button .

2. In the Print dialog box, specify the printer you want to use and the number of
copies you want.

3. To set what items are included in your printout, click the Options button.

4. Click the OK button to initiate the Print operation.

Setting Print Options

To specify what items are included in your printout:

1. Select the File menu, choose Print, and click the Options button in the Print
dialog box or select the Tools menu, choose Options, and click the Print tab of
the Options dialog box.

2. Click the check box beside the items you want to include in each printout:

• Graphical profile picture:  Prints a graphic version of the profile, showing
the component icons and their connections.  The default state of this
selection is On.
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• Component associated data:  Prints the data specified in the dialog box for
each component in the profile.  The default state of this selection is On.

• Register mapping:  Prints the complete register mapping for the target
controller.  The default state of this selection is On.

• Target configuration:  Prints the data specified in the Configuration dialog
box.  The default state of this selection if Off.

• Native language statements:  Prints a representation of the profile in the
target controller’s native language.  For example, if the target controller is
a Power Mate H, the listing will be printed in RS274 language.  The
default state of this selection is Off.

3. Click the OK button.
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Creating Custom Components

CIMPLICITY Motion Programmer features many commonly used motion-related
functions available as components for use in your motion profile. Since your system
may require functions not available through the standard components, the Motion
Programmer gives you the ability to create custom functions through the Text
component or the User-Defined Component feature.

Chapter Contents

This chapter provides the following information:

• How to create a custom component using the Text component

• How to create a user-defined component (UDC)

• How to create a user-defined component library

Chapter

5
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Using the Text Component

The Text component allows you to type native language statements targeted to your
controller then insert the customized action into your motion profile. Any profiles
not created in CIMPLICITY Motion Programmer that are uploaded from the
controller to your personal computer will also appear as native language statements
within a Text component. For complex actions that involve a series of steps, or
actions which may be used in more than one motion profile, you may want to use
the User-Defined Component feature.

Figure 5-1.  Text Component Data dialog box

The Power Mate H and Motion Mate MCS700 Series controllers use the RS274
language. For more information about this language, refer to Appendix B, “RS274
Language Reference.”

The Motion Mate APM300 Series and Motion Mate DSM300 Series controllers use
the Motion Mate APM/DSM Native language. For more information about this
language, refer to Appendix C, “Motion Mate APM/DSM Language Reference.
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Creating User-Defined Components

You can create your own components that can later be inserted in a motion profile.
Once created, a user-defined component (UDC) can be used in multiple motion
profiles. Just like a standard components, a user-defined component features its own
toolbar button, programming icon, associated data dialog box, and even optional
online help.

CIMPLICITY Motion Programmer contains all of the tools necessary to create a
user-defined component, including utilities to help you design toolbar and
programming icons and a dialog box.

When you create a user-defined component, you typically do the following:

• Define the component’s target controller and the number of axes in the system

• Specify what functions are contained in that component

• Indicate the name of the component and which toolbar button and
programming icons will be used for the component

• Design a dialog box containing the parameters the user will need to define to
make the component valid in a motion profile

• Create online help to assist users with the details of the component

After you have created the user-defined components you want, you can create a
UDC library to display the components of that library in a custom toolbar.

Creating a New User-Defined Component

To create a new user-defined component and specify what functions are contained
in the component, do the following:

1. Go to the Tools menu and choose Define Component. The Define Component
dialog box will appear:

Figure 5-2.  The Define Component dialog box



5-4 Using CIMPLICITY Motion  – November 1997 GFK-1362A

5

2. In the Define Component dialog box, specify the target controller (only Motion
Mate APM300 Series, Power Mate H, Motion Mate MCS700 Series, and
Motion Mate DSM300 Series are valid targets for release 2.0 of CIMPLICITY
Motion) and the number of axes in your system. Click the OK button.

3. A window called Comp1 will appear displaying UDC Start and End
components:

Figure 5-3.  The User-Defined Component Profile window

4. Specify the functions of your UDC by adding components to the window and
creating a profile. The same tools and functions used to create a motion profile
are available in this window. Be sure to connect the components you add to the
UDC profile.

5. Once your UDC profile is complete, double-click the Start component and
specify the name, toolbar and programming icons, and other details about the
new component. Your new component will not be valid until this dialog box is
completed.
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Specifying Details about Your New User-Defined
Component

Through the User-Defined Component Start Component Data dialog box (accessed
by double-clicking the Start component in your UDC profile window), you can
specify your UDC’s name, its toolbar button and programming icons, the dialog box
users will need to complete to make the component valid, and optional online help
you can write to assist users of your UDC.

Figure 5-4.  The User Defined Component Start Component Data dialog box

Naming the User-Defined Component

Type the name you want for the component in the Component Name field.

Choosing a Toolbar Bitmap

Type the path of the graphic you want to use for the component’s toolbar button or
click the Browse button to search for the icon. Toolbar bitmaps should be 16 x 16.

For your convenience, CIMPLICITY Motion Programmer contains a bitmap editing
program that you can use to create and edit your own bitmaps. To access this
program, go to the Tools menu and choose Edit Bitmap. Assistance in using this
program is available through the utility’s Help menu.

See page 5-7 for an introduction to the Bitmap Editor. For more detailed
information about using the utility, consult online help within the Bitmap Editor.
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Choosing a Programming Bitmap

Type the path of the graphic you want to use for the component as it will appear
when placed in the profile window or click the Browse button to search for the icon.
Programming bitmaps should be 34 x 34.

For your convenience, CIMPLICITY Motion Programmer contains a bitmap editing
program that you can use to create and edit your own bitmaps. To access this
program, go to the Tools menu and choose Edit Bitmap. Assistance in using this
program is available through the utility’s Help menu.

See page 5-7 for an introduction to the Bitmap Editor. For more detailed
information about using the utility, consult online help within the Bitmap Editor.

Creating a Dialog Box

To make your component valid in a motion profile, users will need to complete a
dialog box containing appropriate parameters for that component. You can create
your own custom dialog box through the dialog box editing program contained in
CIMPLICITY Motion Programmer.

To access the dialog box editor, click the Dialog Box button. Assistance in using
this program is available through the utility’s Help menu.

See page 5-10 for an introduction to the Dialog Box Editor. For more detailed
information about using the utility, consult online help within the Dialog Box
Editor.

Creating Online Help

If you want to provide future users of your UDC with special information or tips on
using the component, you can create online help for the component that users can
access by pressing the Help button in the component’s dialog box.
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To create online help for your UDC, click the Online Help button. The User-
Defined Component Online Help dialog box will appear:

Figure 5-5.  The User Defined Component Online Help dialog box

Using the Bitmap Editor Utility

The Bitmap Editor is a utility that allows you to create a bitmap image to use for a
toolbar button and programming icon for your user-defined component (UDC).

For each UDC you create you will need to create a 16x16 bitmap for the toolbar
button and a 34x34 bitmap for the programming icon that appears in the motion
profile. Once you have created your bitmap, the Bitmap Editor will add the
appropriate shading to your bitmap so it matches the look of the other standard
toolbar buttons and programming icons within CIMPLICITY Motion Programmer.

The Bitmap Editor includes a design grid, a toolbox containing the draw and fill
tools you will need, a view box for seeing your design in its actual size, and a color
palette for choosing and mixing colors.

To access the Bitmap Editor from CIMPLICITY Motion Programmer, go to the
Tools menu and choose Edit Bitmap. For details about using this utility, consult
online help within the Bitmap Editor.
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Figure 5-6.  The Bitmap Editor utility

Toolbox

Pencil:  Draws a free-form line one pixel wide using the current color.

Brush: Paints an bitmap up to five pixels wide (width is selectable through the
Options menu) using the current color.

Pick Rectangle:  Selects a rectangular region in the bitmap.

Line:  Draws a straight line one pixel wide between selected begin and end
points using the current color.

Rectangle:  Draws a hollow rectangle one pixel wide using the current color.
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Filled Rectangle:  Draws a rectangle and fills it with the current color.

Circle:  Draws a hollow circle or ellipse once pixel wide using the current
color.

Filled Circle:  Draws a circle or ellipse and fills it with the current color.

Flood Fill:  Fills the entire grid with the current color.

Tips on Designing Bitmaps

• The toolbar button and programming icon for your UDC should be very
similar. To quickly transfer the basic bitmap, copy the 16x16 bitmap then paste
it into the 34x34 grid.  Then you can edit the bitmap for your UDC.

• The Bitmap Editor automatically adds the appropriate borders or shading
around your bitmap so that it looks like standard Motion Programmer toolbar
buttons and programming icons. Therefore, avoid drawing to the edges of the
drawing area since one to two pixels worth of border will be overwritten.

• About 10% of the adult male population has some form of color confusion. For
this reason, do not rely on color alone to indicate a property or function.

• Use the View window to see how the bitmap will look in its actual size. For
example, letters formed on the drawing area may not be readable as a 16x16
toolbar button.
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Using the Dialog Box Editor Utility

The Dialog Editor is a utility that allows you to create a custom dialog box to
accompany your user-defined component (UDC). Design your dialog box to include
fields in which users must enter data such as position, velocity, etc. New dialog
boxes already include a Comment field as well as OK, Cancel, and Help push
buttons.

To access the Dialog Box Editor, double-click the UDC Start component within the
UDC profile window. In the UDC Start Component dialog box, click the Dialog
Box button. For details about using this utility, consult online help within the
Dialog Box Editor.

Figure 5-7.  The Dialog Box Editor utility

Toolbox

The toolbox is a window containing buttons for the controls you can add to the
dialog box.

To add a control to the dialog box, click the appropriate button then click the area
of the dialog where you want the control.

Text:  Adds a Text control to the dialog box.

Group Box:  Adds a Group Box control to the dialog box.

Edit Field:  Adds an Edit Field control to the dialog box.
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Creating User-Defined Component Libraries

Once you have created one or more user-defined components, you can make the
components available to users by creating a UDC library whose components can
then be displayed in the Motion Programmer as a toolbar.

Creating a New Library

To create a new UDC Library, do the following:

1. Go to the Tools menu and choose Create Library. The Edit Library dialog box
will appear:

Figure 5-8.  The Edit Library dialog box

2. Type the name you want for the library’s toolbar in the Toolbar Name field.

3. Navigate through the directory under UDC Files to locate the directory
containing the UDC component files you want. The .UDC files will appear in
the right-hand box.
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4. Click the .UDC file you want then click the Add button. To add all the .UDC
files listed, click the Add All button. The components currently in the library
will appear in the box under Library Files.

5. When you have finished adding the .UDC files you want, click the Save button.

Editing an Existing Library

To edit an existing UDC Library, do the following:

1. Go to the Tools menu and choose Edit Library.

2. In the Open dialog box, select the location of the library (.CLB) file you want to
edit then click the Open button. The Edit Library dialog box will appear.

3. To add new UDC components to the library, navigate through the directory
under UDC Files to locate the directory containing the UDC component files
you want, click the file’s name in the right hand box, then click the Add button.

4. To remove a UDC component from the library, click the file’s name in the
Library Files box and click the Remove button.

5. When you have finished editing the library, click the Save button.

Importing a Library

To import a library created in another copy of CIMPLICITY Motion Programmer,
do the following:

1. Go to the Tools menu and choose Import Library.

2. In the Import Library dialog box, select the location of the library (.CLB) file
you want to import then click the Open button.
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Communicating with the Target Controller

This chapter describes how to connect and communicate with the target controller
for both CIMPLICITY Motion Configurator and CIMPLICITY Motion
Programmer. Refer to Appendix B for details about the cables and connectors
needed to connect the controller to your personal computer.

Chapter Contents

This chapter provides the following information:

• How to connect your computer to the controller

• How to set communication parameters

• How to download or upload data

• How to monitor profile execution (for the Motion Mate APM300 or Motion
DSM300)

Chapter

6
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Connecting Your Computer to the Target Controller

Before you can download or upload a motion profile, you must connect your
personal computer to the motion controller and specify the communications
parameters.

A special communication cable is required to connect your PC to the target
controller. This cable can be ordered from GE Fanuc or you can build your own.
Refer to Appendix B for cable specifications.

Power Mate D, Power Mate H, or Motion Mate MCS700
Series

The communication cable (Part # 44C742367-001R02) connects the RS-232 port on
the controller with the 9-pin serial port of your PC. Refer to Appendix B for more
connection details. If your PC is equipped with a 25-pin serial port, you must
purchase a 25-pin serial port adapter (this part is available at most computer stores).

RS-232-C
(JD5)

Power Mate D

      

RS-232-C
(JD5)

Power Mate H

RS-232-C
(JD28)

OK
SO

WD
SI

Motion Mate
MCS700

Figure 6-1.  RS-232-C Ports on the Power Mate D, Power Mate H, and Motion Mate
MCS700
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Motion Mate APM300 Series or Motion Mate DSM300 Series

The connection between your PC and the controller is typically made from the RS-
232 port of the computer through an RS-232 to RS-485/RS-422 converter to the
SNP Serial Communication Connector on the APM300. A Miniconverter Kit
(IC690ACC901) which includes a converter and 6 foot cable is available for this
purpose. Refer to Appendix B for further details.

DIGITALSERVO

JS2

INTERFACE

JS1

JD35

STAT

OK

CFG

EN1

EN2

ONE
AXIS

AB

C
O
M
M

STAT

Motion Mate
APM300

RS-232

Figure 6-2.  RS-232 Ports on the Motion Mate APM300 and Motion Mate DSM300

COMM
STAT

OK
CFG

EN3 EN1
EN4 EN2

C A

D B

Motion Mate
DSM300
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Setting Communications Parameters

Before you can begin a download or upload procedure, you must first specify your
PC’s communication settings.

CIMPLICITY Motion Configurator

To set communication parameters in CIMPLICITY Motion Configurator:

1. Select the Target menu, choose Connections, then select Xon/Xoff. The
Xon/Xoff Settings dialog box will appear:

Figure 6-3.  Xon/Xoff Settings dialog box

2. Specify your personal computer’s serial port, baud rate, and number of stop
bits.

3. Click the Save Settings button.
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CIMPLICITY Motion Programmer

To set communication parameters in CIMPLICITY Motion Programmer:

1. Select the Tools menu and choose Options.

2. In the Options dialog box, click the Communications tab:

Figure 6-4.  Communications tab of the Options dialog box

3. In the lower right hand corner of the tab, specify your personal computers baud
rate, the serial port you are using, and the parity and number of stop bits.

4. If your target controller is an APM300 or a DSM300, you must also provide
SNP timeout values. The default timeout values should work for most cable-
connected communications. You may need to increase the timeout values if a
modem is used.

5. Click the OK button.
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Verifying Your Controller’s Communications Parameters

You may need verify or change the communications parameters on the target
controller to ensure they match those on your personal computer and the settings
you provided in the Motion Configurator or Motion Programmer. For more detailed
information about viewing and changing configuration parameters on your target
controller, consult the controller’s startup or connection manual.

On the Power Mate D, Power Mate H, or Motion Mate MCS700 Series:

Use the CRT/MDI (Power Mate D or H only) or the DPL/MDI hand-held unit to
verify that the controller’s serial port configuration is the same as your personal
computer:

Table 6-1.  Communications Parameters on the Power Mate D, Power Mate H, and
Motion Mate MCS700

Setting Parameter Details

ISO Code 0000, bit 1 0 = EIA‡, 1 - ISO*

I/O Channel 0020 0 = 0‡*, 1 = 1

Stop Bits 0101, bit 0 0 = 1, 1 = 2‡*

Feed 0101, bit 7 0 = output‡, 1 = not output*

I/O Device 0102 0 = RS232C*

Baud Rate 0103 10 = 4800‡, 11 = 9600*, 12 = 19200

Parity N/A Always even parity

‡ Indicates a factory default setting

* Indicates a recommended setting
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On the Motion Mate APM300 Series or Motion Mate DSM300 Series:

Use CIMPLICITY Control for Series 90-30 or Logicmaster 90-30 to verify that the
controller’s serial port configuration is the same as your personal computer:

Table 6-2.  Communications Parameters on the Motion Mate APM300 or DSM300

Setting Values Default

Baud Rate 300, 600, 1200, 2400, 4800, 9600, 19200 19200

Parity Odd, Even, None Odd

Stop Bits 1 or 2 1

Data Bits 7 or 8 8

Modem turn-
around time

0 to 2550 in multiples of 10 ms 0 ms

Idle time 1 to 60 sec 10 sec

SNP ID 6 characters consisting of A-F and 0-9. 1st

character must be A-F
A00001
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Downloading and Uploading Data

The Download command sends the currently targeted project folder in
CIMPLICITY Motion Configurator or Programmer from your personal computer to
the target controller. The Upload command sends parameter information or a
motion program from the target controller to your personal computer.

Downloading to the Motion Controller

The Download command stores the current project folder to the target controller.
You may have to change the mode of the target controller before attempting a
download.

Downloading to the Power Mate D, Power Mate H, or Motion Mate MCS700
Using the DPL/MDI Interface

To download the current profile to the target motion controller (which uses a
DPL/MDI interface):

1. Confirm that your PC is physically connected to the controller and that the
motion controller’s communication parameters and your personal computer’s
serial port settings are identical.

2. Confirm that no alarms or reset conditions are present on the motion controller.

3. Select the EDIT mode on the control.

4. On the DPL/MDI interface, press the [PRGRM] softkey then the [READ]
softkey.

5. In CIMPLICITY Motion Configurator or Programmer, confirm that the current
profile targets the correct controller (the selected target is listed on the status
bar at the bottom of the screen).

6. Select the Target menu and choose Download or click the Download toolbar

button .
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Downloading to the Power Mate D or Power Mate H Using the CRT/MDI
Interface

To download the current profile to the target motion controller (which uses a
CRT/MDI interface):

1. Confirm that your PC is physically connected to the controller and that the
motion controller’s communication parameters and your personal computer’s
serial port settings are identical.

2. Confirm that no alarms or reset conditions are present on the motion controller.

3. Select the EDIT mode on the control.

4. Enter the following sequence on the CRT/MDI’s softkeys:  [PRGRM], [OPRT],
[+], [READ], [EXEC].

5. In CIMPLICITY Motion Configurator or Programmer, confirm that the current
profile targets the correct controller (the selected target is listed on the status
bar at the bottom of the screen).

6. Select the Target menu and choose Download or click the Download toolbar

button .

Downloading to the Motion Mate APM300 Series or Motion Mate DSM300
Series:

1. Confirm that your PC is physically connected to the SNP serial port of the
motion controller and that the communication parameters are correct.

2. In CIMPLICITY Motion Configurator or Programmer, confirm that the current
profile targets the correct controller (the selected target is listed on the status
bar at the bottom of the screen).

3. Select the Target menu and choose Download or click the Download toolbar

button .
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Uploading to the PC

The Upload feature retrieves configuration information or a profile from the target
controller and loads it onto your computer.

Uploading from the Power Mate D, Power Mate H, or Motion Mate MCS700
Using the DPL/MDI Interface

To upload the selected profile from the target motion controller (which uses a
DPL/MDI interface) into your personal computer:

1. Confirm that your PC is physically connected to the controller and that the
motion controller’s communication parameters and your personal computer’s
serial port settings are identical.

2. Confirm that no alarms or reset conditions are present on the motion controller.

3. Select the EDIT mode on the control.

4. On the DPL/MDI interface, press the [PRGRM] softkey then the [WRITE]
softkey.

5. In CIMPLICITY Motion Configurator or Programmer, select the Target menu

and choose Upload or click the Upload toolbar button .

• If you are using the Motion Configurator, the Upload Parameters dialog
box will appear. Specify whether the uploaded data will be saved as a new
edition or will overwrite an existing one. If you select the Overwrite
Another edition option, a box will appear to allow you to select the edition
to overwrite.

• If you are using the Motion Programmer and the motion profile you are
uploading was not created in CIMPLICITY Motion Programmer, the
profile will appear on the screen as a Text component.
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Uploading from the Power Mate D or Power Mate H Using the CRT/MDI
Interface

To upload the selected profile from the target motion controller (which uses a
CRT/MDI interface):

1. Confirm that your PC is physically connected to the controller and that the
motion controller’s communication parameters and your personal computer’s
serial port settings are identical.

2. Confirm that no alarms or reset conditions are present on the motion controller.

3. Select the EDIT mode on the control.

4. Enter the following sequence on the CRT/MDI’s softkeys:  [PRGRM], [OPRT],
[+], [PUNCH], [EXEC].

5. In CIMPLICITY Motion Configurator or Programmer, select the Target menu

and choose Upload or click the Upload toolbar button .

• If you are using the Motion Configurator, the Upload Parameters dialog
box will appear. Specify whether the uploaded data will be saved as a new
edition or will overwrite an existing one. If you select the Overwrite
Another edition option, a box will appear to allow you to select the edition
to overwrite.

• If you are using the Motion Programmer and the motion profile you are
uploading was not created in CIMPLICITY Motion Programmer, the
profile will appear on the screen as a Text component.

Uploading from the Motion Mate APM300 Series or Motion Mate DSM300
Series:

1. Confirm that your PC is physically connected to the SNP serial port of the
motion controller and that the communication parameters are correct.

2. In CIMPLICITY Motion Configurator or Programmer, select the Target menu

and choose Upload or click the Upload toolbar button .

• If you are using the Motion Configurator, the Upload Parameters dialog
box will appear. Specify whether the uploaded data will be saved as a new
edition or will overwrite an existing one. If you select the Overwrite
Another edition option, a box will appear to allow you to select the edition
to overwrite.
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• If you are using the Motion Programmer and the motion profile you are
uploading was not created in CIMPLICITY Motion Programmer, the
profile will appear on the screen as a Text component.

Monitoring Profile Execution

The Monitor option in CIMPLICITY Motion Programmer allows you to view the
status of  inputs and outputs while a profile is being executed in the controller. This
option is available for profiles targeting the APM300 or DSM300 only.

To view the status of inputs and outputs do the following:

1. Confirm that your PC is physically connected to the controller and a profile is
currently executing in the controller.

2. Go to the Target menu and choose Monitor.

The Inputs & Outputs dialog box will appear displaying the status of inputs and
outputs for each axis in your system.
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Connection Details

This appendix provides details about the cables and connectors used for serial
communications from your personal computer to the target controller.

Chapter Contents

This chapter provides the following information:

• Connection information for the RS-232-C cable used with the Power Mate D,
Power Mate H, and Motion Mate MSC700 Series controllers

• Connection information for the Miniconverter Kit used with the Motion Mate
APM300 Series and Motion Mate DSM300 Series controllers

• Connection information for the Station Manager cable used with some models
of the Motion Mate DSM300 Series controllers

Appendix

A
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Power Mate D/Power Mate H/Motion Mate MSC700 RS-232-C
Cable

The RS-232-C cable required to connect your personal computer to the Power Mate
D, Power Mate H, or Motion Mate MSC700 controller can be ordered from GE
Fanuc (part # 44C742367-001) or you can build your own cable following the
specifications given below.

Table A-1.  RS-232-C Cable Specifications

Cable: 10 pair, 28 AWG stranded 80°, 60% braid shield, and PCV chrome jacket; cut shield
braid and unused wires on both ends; insulate ends with heat shrink tubing

Controller-side
connector:

Connector:  Honda Tsushin Kogyo Co., Ltd. PCR-E20FS; Hood:  Honda  PCS-20LB
1

2
3

4
5

6
7

8
9

10

12
14 16 18 20

11 13 15 17 19

PC-side
connector:

Connector:  Nihon AMP 205203-3 (DB-9S); Cover:  Nihon AMP 749914-2 or
equivalent

3–RDRD–1

0V–2

6–DRDR–3

0V–4

8–CSCS–5

0V–6

1–CDCD–7

0V–8

9

10

2–SDSD–11

0V–12

4–ERER–13

0V–14

5–SG

7–RSRS–15

0V–16

17

18

19

20

Controller PC

Figure A-1.  RS-232-C Cable Pin-out
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Motion Mate APM300/DSM300 Miniconverter Kit

The Miniconverter Kit (IC690ACC901) consists of an RS-422 (SNP) to RS-232
Miniconverter, a 6 foot (2 meter) serial extension cable, and a 9-pin to 25-pin
converter plug assembly.  The 15-pin SNP port connector on the Miniconverter
plugs directly into the serial port connector on the Motion Mate APM300 or Motion
Mate DSM300 controller. One end of the extension cable plugs into the
Miniconverter’s 9-pin serial port connector while the other end plugs into the 9-pin
serial port of the computer.

a44985

RS-232
PORT

RS-422
PORT

Figure A-2.  Series 90 SNP to RS-232 Miniconverter

Pin Assignments, RS-232 Port

The pinout of the Miniconverter is shown in the following two tables.  The first
table shows the pinout for the RS-232 port.  The direction of signal flow is with
respect to the Miniconverter.

Table A-2  Miniconverter RS-232 Port

Pin Signal Name Direction

2 SD - Send Data Output

3 RD - Receive Data Input

5 GND - Ground n/a

7 CTS - Clear To Send Input

8 RTS - Request To Send Output

The pinouts were chosen to allow direct connection, using a straight through, or 1
to 1 cable (as provided with kit), to the personal computer.  Most computers
equipped with an RS-232 port will provide a pinout compatible with the one shown
above.
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Pin Assignments, RS-422 Port

The following table shows the pinout for the Miniconverter’s RS-422 serial port.
The direction of signal flow is also with respect to the Miniconverter.

Table A-3. Miniconverter RS-422 Port

Pin Signal Name Direction

1 SHLD - Shield n/a

5 +5 VDC - Power Input

6 CTS(A’) - Clear To Send Input

7 GND - Ground n/a

8 RTS(B) - Request To Send Output

9 RT - Receive Termination Output

10 SD(A) - Send Data Output

11 SD(B) - Send Data Output

12 RD(A’) - Receive Data Input

13 RD(B’) - Receive Data Input

14 CTS(B’) Clear To Send Input

15 RTS(A) - Request To Send Output

Cable Diagram (Point-To-Point)

When connecting the Miniconverter to your computer, use the following cable
connections:

RXD
TXD
RTS
CTS
GND
DCD
DSR
DTR

2
3
7
8
5

TXD
RXD
CTS
RTS
GND

PIN

2
3
7
8
5
1
6
4

MINICONVERTER
RS-232 PORT

PC

PIN

Figure A-3. Miniconverter to PC
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Table A-4. Miniconverter Specifications

Mechanical:

RS-422 15-pin D shell male for direct mounting to Series 90 serial
port

RS-232 9-pin D shell male for connection to RS-232 serial port of a
PC

Electrical and General:

Voltage Supply +5 VDC (supplied by PLC power supply)

Typical Current Version A (IC690ACC901A) - 150 mA
Version B (IC690ACC901B) - 100 mA

Operating Temperature 0 to 70° C  (32 to 158° F)

Baud Rate 38.4K Baud maximum

Conformance EIA-422 (Balanced Line) or EIA-423 (Unbalanced Line)

Ground Isolation Not provided

Motion Mate Station Manager Cable

Some Motion Mate DSM300 Series controllers use a station manager cable
(IC693CBL316A). Consult the start-up or user documentation for your motion
controller for more information.

Table A-5.  RS-232-C Cable Specifications

Cable: 6 conductor, shielded with drain wire, non-paired, AWG 26; C&M Cable
Corp., no. 6C26 or equivalent; black PVC jacket; cable length = 3 meters
(± 25 mm)

Controller-side
connector:

6-position modular long body plug (RJ-12), Nihon AMP 5-555174-2 or
equivalent; contact finish is gold flash .000050 THK gold in localized
gold plate area and gold flash over remainder, over .000100 nickel
underplate

PC-side
connector:

9-pin “D” subminiature female type, Nihon AMP 205203-1 or equivalent;
contact finish is .000030 min. gold over .00005 min. nickel for 9-pin
contacts

Cable clamp: • No cable clamp on controller-side connector;
• PC-side connector is a 9-pin straight exit type–Nihon AMP 207908-1

or equivalent
• Must have continuous shielding through the cable clamp
• Must provide screwlock hardware for securing cable to equipment;

need #4-40 screws on 9-pin connector end
• PC-side connector hood must be black in color
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1

2

3

4

5

6

case

7

8

9

10

11

12

case

Controller PC

Figure A-4.  Wire Table for the Station Manager Cable
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RS274 Language Reference

The RS274 part programming language is used to create customized motion
programs for the Power Mate H and Motion Mate MCS700 Series.  These programs
are created using the Text component; the component containing the program can
then be added to a motion profile.

You can include any of the RS274 programming codes in the Text Component:

• O code: specifies the program number.

• G code: identifies a preparatory function

• N word: specifies the sequence number (one for each block)

• F word: specifies the feed rate.

• H code: address for the tool length offset value.

• M code: specifies the on-off operation of the components of the machine

This appendix contains quick reference information about G codes.  For information
about other RS274 codes and detailed explanations, examples, and warnings
concerning the use of G codes, consult the operator’s manual for your controller.

Appendix

B



B-2 Using CIMPLICITY Motion  – November 1997 GFK-1362A

B

Positioning (G00)

The G00 command moves a tool to the position specified with an absolute or
incremental command at a rapid traverse rate.  In the absolute command, the
coordinate value of the end point is programmed.  In the incremental command, the
distance that the tool moves is programmed.

Format:

G00IP_;

IP_: For an absolute command, IP specifies the coordinates of an end position.  For
an incremental command, IP specifies the distance the tool moves.

Linear Interpolation (G01)

Tools can move along a line to the specified position at the feedrate, F.  The value
for feedrate is in effect until a new value is specified. The feedrate value does not
need to be specified for each block.  If F is not set, a value of 0 is used.

Format:

G01IP_;

IP_: For an absolute command, IP specifies the coordinates of an end position.  For
an incremental command, IP specifies the distance the tool moves.

F_: Speed of tool feed (Feedrate)

Skip Function (G31)

Linear interpolation can be performed by specifying an axial move following the
G31 command.  If an external skip signal is received during the execution of this
command, command execution is interrupted and the next block is executed.

The skip function may be used when the end of moving is specified through an
external signal from the machine.  It may also be used for measuring the dimensions
of a workpiece.

Format:

G31IP_;

IP_: One-shot G code (effective only in the block in which it is specified)
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Feed at Programmed Rate (G94/G95)

The feed at programmed rate commands are used to minimize a feedrate change
from the execution of one block to the next block. There are two modes for feedrate:

• Feed per minute (G94)

• Feed per revolution (G95)

Format:

G94 ; G code for feed per minute
F_; Feedrate command (mm/min or inch/min)

G95 ; G code for feed per revolution
F_; Feedrate command (mm/rev or inch/rev)

Rate Feed (G93)

You can specify the feed mode through the G93 command and specify the tool's
final velocity directly by the value following F.  This code relies on settings for F in
preceding blocks to work properly.

Dwell, Exact Stop (G04)

You can delay the execution of the next block by using the Dwell command.  A
dwell can also be used to make an exact check in the feed-at programmed rate.

Format:

G04 X_; or G04 P_;

X_: Time (decimal point permitted)
P_: Time (decimal point not permitted)
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Reference Position Return Check (G27)

This command verifies that the tool has correctly returned to the reference position
specified in the program.  If the tool reaches the reference position, the reference
position return light is lit. If the position reached by the tool is not the reference
position, an alarm (No. 092) is displayed.

Format:

G27 IP_;

IP_: Reference position (absolute/incremental command)

Reference Position Return (G28)

This block is used to specify the coordinates for the intermediate position.  If this
block is included in the program, these values are stored in the controller for the
axes specified in the command.

Because positioning to the intermediate or reference positions is performed at the
rapid traverse rate of each axis, the tool length compensation should be canceled
before executing this command.

Example Format:

N1 G28 X40.0 ; Intermediate position (X40.0)
N2 G28 Y60.0 ; Intermediate position (X40.0 Y60.0)

Return from Reference Position (G29)

This command is typically executed immediately following the G28 or G30
commands.  For incremental programming, the command value specifies the
incremental value from the intermediate point.

2nd and 3rd Reference Position Return (G30)

In a system without an absolute position detector, the 2nd and 3rd reference position
return functions may only be used after the G28 command or manual reference
position return is made.



GFK-1362A Appendix B  RS274 Language Reference B-5

B

Setting for Work Coordinate System (G92)

A workpiece coordinate system is set so that a point on the tool, such as the tool tip,
is located at specified coordinates.  The user can set the workpiece coordinate
system in one of two ways:

• Using the G92 command:
G92 IP_

• Automatic setting:  If bit 0 of parameter No. 1201 is set beforehand, the
workpiece coordinate system is automatically set when manual reference
position return is performed.

Plane Selection (G17, G18, G19)

This command selects the plane used for machining.

G Code Selected Plane

G17 Xp Yp plane

G18 Zp Xp plane

G19 Yp Zp plane

Absolute Programming (G90)

There are two ways to command tool travel–absolute or incremental.

In the absolute command, the coordinate values of the end position are
programmed. Once a G90 command is issued, all subsequent commands will be
interpreted as absolute commands until a G91 code is issued.

Format:

G90 IP_;
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Incremental Programming (G91)

There are two ways to command travels of the tool–absolute or incremental.

In the incremental command, move distance of the position itself is programmed.
Once a G91 command is issued, all subsequent commands will be interpreted as
incremental commands until a G90 code is issued.

Format:

G91 IP_;

Inch/Metric Conversion (G20,G21)

This code is used to select either inch or metric input to the system. This code must
be specified in an independent block before setting the coordinate system at the
beginning of the program.

Format:

G20 ; Inch input
G21 ; mm input

Tool Length Offset (G43, G44, G49)

This function is used to compensate the difference between the tool length value
used in the program and the length of the tool.  This allows the program to run
correctly without changing the program to match the tool.

G43 and G44 codes are used to specify the direction of the offset (G43 + direction,
G44 – direction).  G49 is used to cancel the tool length compensation.
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Data Entry (G10, G11)

Data entry mode may be used to set parameter values from a program  Use G11 to
cancel data entry mode.

Format:

G10L50; Parameter entry mode setting
N_R_; For parameters other than the axis type
N_P_R_; For axis type parameters
G11; Parameter entry mode cancel

N_: Parameter No. (4digits)
R_: Parameter setting value (Leading zeros can be omitted.)
P_: Axis No. 1 to 8 (Specifying for entering axis type Param)

Macro Statement (G65)

The G65 macro call command identifies a custom macro.  This custom macro
executes whenever the macro call executes.

Format

G65 P L <argument>

P: Number of the program to call
L: Repetition count
Argument: Data passed to the macro
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Motion Mate APM/DSM Language Reference

The Motion Mate APM300/DSM300 programming language is used to create
customized motion programs for the Motion Mate APM300 Series and Motion Mate
DSM300 Series.  These programs are created using the Text component; the
component containing the program can then be added to a motion profile.

For more information about this language, consult the user or programming manual
for your target controller.

Appendix

C
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Command Summary

The following table summarizes the commands available in the Motion Mate
APM300/DSM300 programming language. The Motion Program does not support
all of the commands through the standard components.  Details about each
command begin on page C-3.

Table C-1.  Motion Mate APM300/DSM300 Commands

Command Range Definition

ACCEL 1 to 134,217,727 Set Acceleration

ACCEL-P 0 to 255 Set Acceleration to data in Parameter

BLOCK 1 to 65,535 Define Block Number

BLOCK-SYNC 1 to 65,535 Define Synchronous Block Number

CMOVE-AL –8,388,608 to 8,388,607 Continuous move, Absolute, Linear

CMOVE-AL-P 0 to 255 Continuous move, Absolute, Linear, Use data in Parameter

CMOVE-AS –8,388,608 to 8,388,607 Continuous move, Absolute, S-curve

CMOVE-AS-P 0 to 255 Continuous move, Absolute,  S-curve, Use data in Parameter

CMOVE-IL –8,388,608 to 8,388,607 Continuous move, Incremental, Linear

CMOVE-IL-P 0 to 255 Continuous move, Incremental, Linear, Use data in
Parameter

CMOVE-IS –8,388,608 to 8,388,607 Continuous move, Incremental, S-curve

CMOVE-IS-P 0 to 255 Continuous move, Incremental, S-curve, Use data in
Parameter

DWELL 0 to 60,000 Wait for specified time in  milliseconds

DWELL-P 0 to 255 Wait X milliseconds, X is the value in the Parameter

LOAD-P01-P20 –8,388,608 to 8,388,607 Load APM300 Parameter register number

NULL 0 Do nothing

PMOVE-AL –8,388,608 to 8,388,607 Positioning move, Absolute, Linear

PMOVE-AL-P 0 to 255 Positioning move, Absolute, Linear, Use data in Parameter

PMOVE-AS –8,388,608 to 8,388,607 Positioning move, Absolute, S-curve

PMOVE-AS-P 0 to 255 Positioning move, Absolute,  S-curve, Use data in Parameter

PMOVE-IL –8,388,608 to 8,388,607 Positioning move, Incremental, Linear

PMOVE-IL-P 0 to 255 Positioning move, Incremental, Linear, Use data in Parameter

PMOVE-IS –8,388,608 to 8,388,607 Positioning move, Incremental, S-curve

PMOVE-IS-P 0 to 255 Positioning move, Incremental,  S-curve, Use data in
Parameter

VELOC 1 to 8,388,607 Set Velocity

VELOC-P 0 to 255 Set Velocity to data in Parameter

WAIT 1 to 12 Wait for CTL XX bit to go high before moving
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Command Details

Acceleration

This command is used to specify the axis acceleration and deceleration rate for
subsequent moves.  Once encountered, the specified rate will remain in effect until
overridden by a later Acceleration command.

Format

• ACCEL     User Units/sec/sec  (1 to 134,217,727)

• ACCEL-P     Parameter Number  (P0 to P255)

Block

Block numbers are used as jump destinations and to control jump testing in the
APM.  They identify the block the APM is currently executing and may be used by a
PLC program to monitor motion program progress.

Format

• BLOCK     Block Number  (1 to 65535)

• BLOCK-SYNC     Block Number  (1 to 65535)

Cmove

This command is used when it is not necessary for the axis to be within the
configured In Position Zone before proceeding to the next command.  If the Cmove
is followed by another Move command, the velocity specified for the Move is
attained at the programmed distance of the previous Move.  If no previous
acceleration or velocity has been specified in a motion program, the configured Jog
Acceleration and/or Jog Velocity will be used.
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Format

I = Incremental, L = Linear, P = Parameter, A= Absolute, S = S-curve

• CMOVE-AL n     User Units (–8,388,608 to +8,388,607)

• CMOVE-AL-P n     Parameter Number (P0 to P255)

• CMOVE-AS n     User Units (–8,388,608 to +8,388,607)

• CMOVE-AS-P n     Parameter Number (P0 to P255)

• CMOVE-IL n     User Units (–8,388,608 to +8,388,607)

• CMOVE-IL-P n     Parameter Number (P0 to P255)

• CMOVE-IS n     User Units (–8,388,608 to +8,388,607)

• CMOVE-IS-P n     Parameter Number (P0 to P255)

Dwell

This command causes motion to cease for a specified time period (in milliseconds)
before proceeding to the next command.  The Program Active status bit will remain
ON during the Dwell, the Moving status bit will be OFF.

Format

• DWELL     Milliseconds (0 to 65,535)

• DWELL-P n     Parameter Number (P0 to P255)

Load Parameter

This command initializes or changes the parameter value.  The new value becomes
effective immediately when encountered in the program.  Parameters 246 — 255
are Special Purpose Function Parameters and data may be written into them by the
controller.

Format

LOAD-P01 to P20     Parameter Value
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Null

This command performs no function.  It can be used at a jump destination when no
command is desired.

Format

NULL

Pmove

This command is used when it is necessary for the axis to be within the configured
In Position Zone before proceeding to the next command.  If no previous
acceleration or velocity has been specified in a motion program, the configured Jog
Acceleration and/or Jog Velocity will be used.

Format

I = Incremental, S = S-curve, P = Parameter, A= Absolute, L = Linear

• PMOVE-AL n     User Units (–8,388,608 to +8,388,607)

• PMOVE-AL-P n     Parameter Number (P0 to P255)

• PMOVE-AS n     User Units (–8,388,608 to +8,388,607)

• PMOVE-AS-P n     Parameter Number (P0 to P255)

• PMOVE-IL n     User Units (–8,388,608 to +8,388,607)

• PMOVE-IS n     User Units (–8,388,608 to +8,388,607)

• PMOVE-IS-P n      Parameter Number (P0 to P255)

Velocity

This command specifies the velocity of axis motion.

Format

• VELOC     User Units/sec (1 - 8,388,607)

• VELOC-P     Parameter Number (P0 to P255)
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Wait

This command synchronizes the start of axis motion with an external input or event
reported in CTL 1-12.   The start of motion is suspended until the bit being
monitored is true.

Format

WAIT     CTL #  (CTL01 - CTL12)
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Arranging multiple profile

windows, 3-13
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4-7
Associated data, 4-6
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B
Backing up and restoring the

motion profile, 3-10
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CIMPLICITY Motion
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transferring a license, 1-6
uninstalling, 1-7

Circular Move Component,
4-18
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3-12
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defining, 4-6

Component details, 4-12
Components

connecting, 4-9
dangling, 4-11
deleting, 4-5
disconnecting, 4-10
input and output handles, 4-4
inserting, 4-4
moving, 4-5
selecting, 4-4

Conditional Jump Component,
4-27

Configuration
editing, 2-4
importing/exporting, 2-6

Configuration Wizard, 2-7
Configuring parameters, 2-7
Connecting components, 4-9
Connection

Motion Mate APM300, 6-3
Motion Mate DSM300, 6-3
Motion Mate MCS700, 6-2
Power Mate H, 6-2

Context-sensitive help, 1-10
Coordinate Position

Component, 4-26
Copy, 4-5
Creating a motion profile, 3-2
Creating and setting project
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Customizing the profile

window, 3-13
Cut, 4-5

D
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using, 4-11
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controller, 3-8
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Downloading the motion
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Edition

creating, 2-4
downloading, 6-8
editing, 2-4
uploading, 6-10

Editions
importing/exporting, 2-6

End Component, 4-14
End While Component, 4-30
Entering and editing

components, 4-2
Execution Conditions

Component, 4-21

G
G codes, B-1

H
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Hardware requirements for the

PC, 1-3

I
Input handles, 4-4
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Installing CIMPLICITY

Motion, 1-4
Invalid components, 4-4

defining component data, 4-6

L
Libraries

creating, 5-11
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Links
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M
Miniconverter kit, A-3
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specifications, A-5
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Monitoring profile execution,
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introduction, 2-2
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connection, 6-3
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Motion Mate DSM300

connection, 6-3
Miniconverter kit, A-3
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language, C-1
Motion Mate MCS700

connection, 6-2
Motion Mate MSC700
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new, 3-2
open, 3-3
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saving, 3-8
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Component, 4-37

Circular Move Component,
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Conditional Jump
Component, 4-27
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Component, 4-26

End Component, 4-14
End While Component, 4-30
Execution Conditions

Component, 4-21
Move Component, 4-15
Reference Point Move

Component, 4-20
Start Component, 4-12
Subroutine Component, 4-35
Synchronize Component,

4-34
Text Component, 4-38
Wait Component, 4-32
While Component, 4-30

Motion profile window, 3-4
mouse icons, 3-5
status bar, 3-13
toolbars, 3-14
using the mouse, 3-5

Mouse icons
motion profile window, 3-5

Move Component, 4-15
Moving components, 4-5

N
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4-38

O
Online documentation, 1-8
Online help, 1-8
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Opening a motion profile, 3-2
Output handles, 4-4

P
Parameters

components, 4-6
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editing, 2-4
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PC hardware requirements,

1-3
Power Mate
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Power Mate H

connection, 6-2
RS232 cable, A-2

Profile size, 4-10
Program

entering, 4-2
Project folder

creating, 3-6
new target, 3-8
setting, 3-6

Project folder
changing, 2-5
creating, 2-5
selecting, 2-5

R
Reference Point Move

Component, 4-20
Registering the software, 1-5
Renaming the motion profile,

3-10
Resizing the profile window,

3-13
RS-232 port, A-3
RS-232-C cable, A-2
RS274 programming

language, B-1
RS-422 port, A-4

S
Saving the motion profile, 3-8
Selecting components, 4-4
Serial communications, 6-4
Serial port configuration, 6-4
Setting profile size, 4-10
Settings

communications, 6-4
Start Component, 4-12
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Status bar
displaying or hiding, 3-13

Subroutine Component, 4-35
Synchronize Component, 4-34

T
Text Component, 4-38
Text component, 5-2
Toolbars

displaying, 3-14
hiding, 3-14
motion profile window, 3-14
moving, 3-15

Transferring a License, 1-6

U
Uninstalling CIMPLICITY

Motion, 1-7
Uploading a motion profile,

6-10
Uploading an edition, 6-10
User-defined component

libraries, 5-11
User-defined components, 5-3

W
Wait Component, 4-32
While Component, 4-30
Wizard, 2-7
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